I have several extensions on a magento site. I suspect one of them is causing a problem and I want to disable them all and then bring them back one at a time to find the problem. Is there any easier way to do this then going into app/etc/modules/* and disabling them individually?

  • Please check - magebase.com/magento-tutorials/… Might help to you... – Pravin Apr 21 '14 at 13:11
  • @Pravin please turn that into an answer I know it's not exactly what I'm looking for myself but it looks like the best answer so far, thanks. – byronyasgur Apr 21 '14 at 21:07

Dont know if helps but the only massive disable that Magento offers is only of local codepoll (app/code/local)

while going through the section on Module loading, it is revealed that we can easily disable all modules living in the local (app/code/local) namespace by editing app/etc/local.xml and setting the disable_local_modules node to true: You can do it in your local xml:

  • Note that this not only excludes local modules from loading but also removes app/code/local from the include path, so that the autoloader will not find any custom backend models, source models etc. for attributes that have been added by extensions. So, in many cases it breaks the store. – Fabian Schmengler Jul 5 '15 at 22:00

Go to

Admin -> System -> Configuration

and in the left on the last menu

ADVANCED -> Advanced

and disable or enable extensions

  • Almost certain that only disables the HTML output for display reasons. – byronyasgur Apr 18 '14 at 19:57
  • Extendware has an extension that can enable or disable all your extensions. also you can use CEM for this job if you can pass email verification – sIiiS Apr 19 '14 at 6:15
  • disable core = remove engine – Fiasco Labs Apr 20 '14 at 0:34
  • @FiascoLabs disable core = remove engine will probably not be very helpful to people visiting this page in the future. Do you care to expand? – byronyasgur Apr 21 '14 at 14:35
  • @sIiiS are you sure? I looked here and it's not listed as far as I can see. – byronyasgur Apr 21 '14 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.