I am using magento community version 1.8.1. I am using FedEx for shipping method.

I enabled several method like 'First Overnight','2 Day','Priority Overnight','Standard Overnight','Ground' and 'International Ground' from admin.

But only four are appearing in front end. 'Ground' and 'International Ground' is not appearing.

Can anyone help me on this ?

  • I found this "FedEx returns the list of shipping methods as a response for our API call. The response is based on the total products weight (sum of all the products weight in cart). So if the total weight is upto 70lbs Ground Shipping will be shown. If the weight is more than 70lbs you can use Home delivery. And if the weight is above 150lbs you can use freight methods." is this correct reason for not showing ground shipment ? Apr 18, 2014 at 4:31

4 Answers 4


I had the same issue. After turning just about every option on and off. I figured out that if the field for "Residential Delivery" is set to 'Yes'. Ground is turned off, but you can select "Home Delivery".


Switch "Residential Delivery" to "Off", this allowed the ground option to display on checkout and estimate page. Not sure if that is a Magento or FedEx API thing, I don't really care to explore it atm. Maybe one of you guys can look into it, for a better fix.

  • Easy fix, thanks! I presume if we leave it enabled and find how to pass if it is a residential or business address we will get the correct options, but haven't dug into that yet.
    – Art Siv
    Jul 29, 2021 at 19:48

I had a similar problem, but mine wasn't related to 'Residential' being set or not - international address post-codes weren't passing validation.
USPS ignored this, but FedEx's API did not.

This issue could be one of many issues and as Magento allows shipping methods to fail silently - I suggest enabling "Debug" for the shipping method, and checking in var/log/shipping_fedex.log and look in the "result" Object.


Turning Residential Delivery to No worked for me.

  • it doesn't work for me. Any other possible solution? Jun 6, 2021 at 12:36

What packaging type have you set in the admin (System->Configuration->Sales->Shipping Methods->FedEx->Packaging)? I think for FEDEX_GROUND you need to set the packaging to 'Your Package'.

But I am not certain of this. The available shipping methods returned by the FedEx API remain an enigma. Try lots of different settings and see what types are returned. Maybe FedEx help desk can tell you the magic settings you need to pass into the API to get FEDEX_GROUND back.

If you want to dive into the code, read /app/code/core/Mage/Usa/Model/Shipping/Carrier/Fedex.php.

  • Thanks for you answer. We found our mistake. our client has added 'ground' shipping method in there FedEx account Apr 19, 2014 at 9:19
  • @VaibhavShahu feel free to add your own answer explaining what changed to make it work. May 28, 2014 at 7:20
  • @vaibhav how to solve fedex ground shipping issue ? same problem with me. it is not appearing in checkout page under shipping method Feb 2, 2017 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.