0

A fairly fresh installation of Magento 2.1.7. 1.9.3.x database migrated over. Everything was working fine, the search worked, until sometime today when it just stopped. The last thing I remember doing was adding the first new product into the Default attribute set (whereas all the other products use migrated_normal_product attribute set. Soon after doing that, search stopped working entirely.

It doesn't find anything, not with SKU, not with the product name. I've tried reindexing and clearing the cache, but to no avail.

Advanced Search can find the products just fine, but not the regular one.

  • have you check your product with Main Website is Selected? – Rakesh Jesadiya Jul 22 '17 at 9:08
  • Yes, the main website is selected for all products. – Mika Salakka Jul 22 '17 at 20:09
0

Check these configurations in your product:

General->Status = Enabled

General->Visibility = Catalog,Search

Inventory->Qty > 0

Inventory->Stock Availability = In Stock

Websites = checking your site

Catgories = checking your category.

If it doesn't resolve, you can use this SQL command in your database:

update indexer_state set status='invalid' where status ='working'
  • All products have "Catalog, Search" as their Visibility, yet none of them can be found through the search function. – Mika Salakka Jul 22 '17 at 7:58
  • I've updated, try to run the SQL. – Rafael Corrêa Gomes Jul 23 '17 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.