2

When I set Use Secure URLs in Admin to "yes" it causes the backend to logout everytime I view something on the front end. Does anyone know what could be causing this. The backend works fine until I browse the site proper ... then it logs me out.

  • 1
    Can you use Google Chrome's debugger (or another tool) to show the cookies set on you site? – Alan Storm Apr 16 '14 at 1:31
  • It sets 5 --utma, --utmb, --utmc, --utmz and adminhtml ... ( facebook also sets 2 datar and lu but I presume that's nothing to do with it) – byronyasgur Apr 16 '14 at 16:44
  • ... it seems to be deleting the cookies and re-setting them every click on the front end ... I have no idea what could be causing this though – byronyasgur Apr 16 '14 at 17:00
4

Based on the comments above, it sounds like your Magento frontend isn't using the frontend cookie for the PHP session. Instead it's using the adminhtml cookie. for both the frontend and backend area. Because of this, when you browse to a frontend page the frontend session code is set in the adminhtml session, and you lose your login.

This (most likely) happened because an extension you installed monkeyed around with the session/cookie setting code in your system, or someone working on the Magento system monkeyed directly with a core file. I wrote an article recently about a similar issue, instantiating session objects too early. Although your issue is different, that article provides some context around how/why Magento session and session cookies are named, and might help you debug this on your own.

Also, this may be as simple as your server time being set incorrectly and the cookies expiring early.

  • thanks ... well I don't think I touched any core files so I'll disable the extensions and see. – byronyasgur Apr 16 '14 at 18:22
  • @byronyasgur You'll also want to check that your cookie domain set in the backend matches your secure domain set in the backend. – Alan Storm Apr 16 '14 at 19:36
  • not sure about cookie domain - I put in my domain prefixed with a period as they said and it locked me out - had to fix via phpmyadmin - magentocommerce.com/wiki/modules_reference/english/… – byronyasgur Apr 18 '14 at 18:03
  • 1
    Traced it back to Balke Store Maintenance ... great extension but apparently you need to set the "use secure in" for admin and front end to 'No' if you want to put the store in maintenance mode and not be logged out ... so it seems anyway. – byronyasgur Apr 22 '14 at 23:55
  • @byronyasgur Blarg — apologies if I sent you down the wrong path. – Alan Storm Apr 23 '14 at 5:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.