1

I am facing an error in Magento 2.1.5. I have changed the product quantity from Magento admin panel but the stock did not update.

I have clean cache already but it still showing out of stock.

Can anyone please help me to solve it.

  • Nobody in there to help me about this issue – Shakib Rahman Jul 18 '17 at 11:50
  • HI @Shakib Rahman I'm facing the same problem now, did you manage to solve it? – Cyberdelphos Sep 27 '18 at 15:55
  • Have you checked setting in admin magento.stackexchange.com/questions/244232/… – Chirag Patel Oct 2 '18 at 11:40
  • @ChiragPatel yes, that config is set to "Yes" – Cyberdelphos Oct 3 '18 at 21:21
  • Reindex php bin/magento indexer:reindex. If you have a big catalog it will take time. Than flush cache php bin/magento cache:flush. Make sure cache is flushed in directory var/cache and var/pagecache – obscure Oct 8 '18 at 9:02
1

Below the product quantity option there is a stock status option make sure that is set to "In Stock".

Stock Status

If this is not your problem please provide some more information as what type of product etc.

  • I have created the new simple product but the stock is not changing and it showing out of stock in the website. – Shakib Rahman Jul 18 '17 at 9:04
  • So changing the stock status in the backend does not work ? – JasonSy Jul 18 '17 at 9:12
  • Yes that is. Stock status does not change. – Shakib Rahman Jul 18 '17 at 9:29
  • Nobody there to help me about this issue – Shakib Rahman Jul 18 '17 at 11:50
  • Have you reindex indexing? Or You can disable cache and Change index sattus to "Update on save" then make your changes for product and check! – Keith Jul 18 '17 at 12:26
1

If you have a custom theme, you must add the attribute isQty = "true"

in magento/app/code/YourCustomTheme/Catalog/etc/product_types.xml for example:

0

Did your site have single store view or multiple store view? If it has multiple store view do check if you are changing the inventory status in correct store. Also change the inventory status of other products to check if it is working for other products.

0

Reindex the Indexing from terminal :

 php bin/magento indexer:reindex

Or You can disable cache and Change index mode to "Update on save" then make your changes for product and check!

0

Maybe your issue is regarding the store. can you please check your store id 0 and 1 values different or the same?

like admin product edit url in last add  /store/0 and store/1 both value may be different.

Once both store wise same value save you need to run command reindexing.

php bin/magento indexer:reindex

Note - https://github.com/magento/magento2/issues/5696#issuecomment-234493524

  • 1
    where do I check the store id? I can't find that setting. The problem I'm facing is that after changing stock value and pressing save, I always get 0, besides the item is available and In Stock, but always with 0 inventory no matter what I do – Cyberdelphos Oct 3 '18 at 21:28
  • you can change 0 to 1 in beside item url then check – Magento2 Devloper Oct 4 '18 at 5:30
  • yes, that's what I did, changed the item stock in the back office, but it didn't work. I changed stock from 0 to 1 but after pressing save, it says 0 again. – Cyberdelphos Oct 5 '18 at 15:05
0

I had the same issue once. It happens when your shop is set to production mode. Disable the cache, change product stock status, save it and enable the cache.

  • Product shows status as "In Stock" and it's ok. The problem is that after updating Product Qty, it remains 0 no matter what quantity I add. – Cyberdelphos Oct 8 '18 at 21:27
  • @Rama Chandran M, Am I do this every time to change each product stock status? – Jaisa Apr 25 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.