I migrated all of the data from a Magento 1.9 build to Magento 2.1.7 everything has gone well. categories are showing, products are in the categories, product images are showing on backend and category pages, all settings have migrated.

However I have one issue, every single product page when clicking from the category returns the Magento 404 and the product pages don't seem to exist, still using luma base theme for testing.

Debug/exception/error logs show nothing.

category page product showing fine The category image/text above links to the following URL:


as expected as per the Magento 1 build.

When editing the product in the backend:

enter image description here

I've re-indexed/cleared cache/ran magento:upgrade. At the end of my knowledge of what could be causing this - has anyone had this issue/have any suggestions on what to try next?

EDIT: Manually added a new product through the admin panel - same result 404 error page, shows in category fine.

  • 1
    check like : domain-name.com/catalog/product/view/id/{product-id}, still there is 404 Jul 17, 2017 at 13:30
  • @EmiproTechnologiesPvt.Ltd. same result 404 magento error page.
    – KojoSlayer
    Jul 17, 2017 at 13:32
  • There is any product content display or 404 page content display there . Jul 17, 2017 at 13:36
  • Just magentos 404 whoops page: i.imgur.com/HUPVqSU.png @EmiproTechnologiesPvt.Ltd.
    – KojoSlayer
    Jul 17, 2017 at 13:38
  • Also check with product is enabled,have qty , in stock and in magento1 there is not given specific theme to that product from design tab Jul 17, 2017 at 13:42

2 Answers 2


Try go to configuration and disable the category in the product URL path, then reindex, see if product pages work. If this works, try setting it back and Reindex again.

  • Disabled the category in the product url. Still same result 404 magento whoops.
    – KojoSlayer
    Jul 17, 2017 at 13:48
  • You may have some issues with URL rewrites. I had a few and ended up truncating the rewrite table. Backup before you try!
    – Matthew
    Jul 17, 2017 at 15:44
  • just to be clear all you did was truncate the rewrite tables (catalog_url_rewrite_product_category and URL_rewrite) then run reindex via ssh?
    – KojoSlayer
    Jul 18, 2017 at 7:10
  • Yes. And clear /pub/static
    – Matthew
    Jul 18, 2017 at 20:10

Please check all product entity(Ids) available in "sequence_product" table. Need product id in that table to init product page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.