0

Magento 1.9.3.4 is not upgrading, showing this fatal error. I've tried many times.

enter image description here

2

Here you can read more about this error and various ways to avoid/solve it.

From the docs:

The most common reason for the MySQL server has gone away error is that the server timed out and closed the connection.

You need to change the maximum execution time and size you can use the following commands to do so:

SET GLOBAL wait_timeout = 6000;
SET GLOBAL max_allowed_packet= 64M;

or you can change the file /etc/my.cnf that corrected this issue for me below:

[mysqld]
max_allowed_packet= 64M
wait_timeout= 6000
0

The usual cause when you get MySQL server has gone away is timeout errors and max_allowed_packet being set too low. These are settings that will have to be made to your system’s my.cnf file by your hosting provider.

https://dev.mysql.com/doc/refman/5.5/en/gone-away.html

The connection to your MySQL server is timing out due a PHP script taking too long to execute, server overload, wretchedly huge requests or a misconfiguration of MySQL.

my.cnf settings that might help…

max_allowed_packet = 16M
wait_timeout = 1800 
connect_timeout = 120

You will need to restart your MySQL server for these settings to load

Try bumping max_allowed_packet incrementally up, you may need 24M-32M.

If you're on shared hosting, it's a good indicator that your shared host is running out of resources and Magento over time has due to database growth, exceeded the shared hosting capabilities to run it.

  • Thanks for reply, but when I tried updating magento, all modules one by one. It worked. Now Magento is updated 1.9.3.4 from 1.9.3.3 – Aks Jul 17 '17 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.