0

Hey guys I got following error:

Warning: SimpleXMLElement::__construct(): in app/code/core/Mage/AdminNotification/Model/Feed.php on line 173

which prevents me from literally everything on the backend because everytime I want to edit a product or an order I get an error 404 message (Still can access the backend).

Now I already tried to google it Magento system.log 'Warning: SimpleXMLElement' - (adminNotification/Model/Feed.php) and people suggest that I had to turn off modules containing Mage_AdminNotification_Model_Feed or "AdminNotification". I literally deleted all the files of the modules which contains these words and deleted the modules from my module folder and I still get this error....

I also loaded a Backup where everything was fine and I STILL get this error... What can I do to fix this or maybe I'm doing it wrong?

The only path/modules I didn't deleted are these:

includes\src\Mage_AdminNotification_Model_Feed.php,
includes\src\Mage_AdminNotification_Model_Observer.php,
includes\src\MSP_Common_Model_Feed.php

2

It looks like something is breaking the adminhtml feed module.

The cause could be a third-party module that is retrieving invalid XML.

Check whether your site code contains any class which extends Mage_AdminNotification_Model_Feed.

Once you find it:

Try to disable that module (in app/etc/modules/). Clean the system.log. See if the error is gone. Repeat this process for each module.

  • I already searched for all those files and disabled them but I still get the same error – ercMatha Jul 13 '17 at 13:41
0

This below files are stored in the compilation folder

includes\src\Mage_AdminNotification_Model_Feed.php, includes\src\Mage_AdminNotification_Model_Observer.php, includes\src\MSP_Common_Model_Feed.php

So first navigate to <magento-root>\includes\config.php and comment both below lines in this config.php file.

#define('COMPILER_INCLUDE_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'src');
#define('COMPILER_COLLECT_PATH', dirname(__FILE__).DIRECTORY_SEPARATOR.'stat');

Than after clear the cache and again do the compile form the admin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.