0

In admin panel under Url options, I want to turn on Store codes on Url, since I want to visit my country-specific pages. I'm running locally (using WAMP) so my IP is 127.0.0.1:8888. I did set my host file so that magento.lan points to 127.0.0.1. Base url is set to magento.lan (but my store is still visited on magento.lan:8888).

The error I'm getting when trying to enable the store codes to url setting is:

Invalid domain name: The input appears to be a DNS hostname but cannot match TLD against known list; The input does not appear to be a valid URI hostname; The input does not appear to be a valid local network name
2

Setting web/url/use_store in core_config_data table to 1 fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.