3

I am trying to install German language pack and its showing me error ' Duplicated translation is found, but it is not allowed '

Commands:

wget https://github.com/mageplaza/magento-2-german-language-pack/raw/master/de_DE.csv

php bin/magento i18n:pack -m replace de_DE.csv de_DE

php bin/magento cache:clean

php bin/magento setup:static-content:deploy de_DE

php bin/magento indexer:reindex

php bin/magento cache:clean

php bin/magento cache:flush

when I run the third command the error is shown. Please help me to fix this error.

Thanks in Advance..

| improve this question | | | | |
  • @Teja bhagavan Kollepara Why are you editing all the post.. if you know the answer post here.. – SUBIN CHANDRAN Jul 28 '17 at 10:53
  • Having the same issue for de-DE and es-AR. Any idea? – Remy Aug 31 '17 at 18:01
1

You have to define '-d' for allow duplicate translation.

use i18n:pack -m replace -d de_DE.csv de_DE command for allow

duplicate translation instead of i18n:pack -m replace de_DE.csv de_DE

here -d => use for allow duplicate translation

Now Your command will be

php bin/magento i18n:pack -m replace -d de_DE.csv de_DE

php bin/magento cache:clean

php bin/magento setup:static-content:deploy de_DE

php bin/magento indexer:reindex

php bin/magento cache:clean

php bin/magento cache:flush

its working for me.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.