0

I am loading an external script on a Magento CMS page. On the CMS page, I have the following div:

<div id="feefo-service-review-widgetId" class="feefo-review-widget-service">
  </div>

And in the footer I put the following script:

<script type="text/javascript" 
 src="https://api.feefo.com/api/javascript/marsden"></script>

The page that should load the info is the following:

http://www.marsden-weighing.co.uk/feefo-2

The problem is that initially not all reviews are loaded. I noticed that if I click on a link and go back, then all reviews are loaded. Is it a problem with the loading of the script? Is there a workaround? I also tried to add 'asycn' but no success :( Any pointer much appreciated.

0

I checked the site in console error. the problem is third party API ("https://api.feefo.com/api/javascript/marsden). So you can allow Access-Control-Allow-Origin in your .htaccess or your php.

For more reference :

https://stackoverflow.com/questions/19743396/cors-cannot-use-wildcard-in-access-control-allow-origin-when-credentials-flag-i?answertab=active#tab-top

  • I added the following to my .htaccess file but still not luck :( # Allow Access-Control-Allow-Origin <IfModule mod_headers.c> Header add Access-Control-Allow-Origin "*" Header add Access-Control-Allow-Headers "origin, x-requested-with, content-type" Header add Access-Control-Allow-Methods "PUT, GET, POST, DELETE, OPTIONS" </IfModule> # End – Shakamal Jul 11 '17 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.