0

I have the following issue:

I copied a project from a server to another.

On the original server, everything works fine, but on the new server i don't have any css or js included in my project.

I run all the commands, like:

php bin/magento setup:upgrade

php bin/magento setup:static-content:deploy(on language) and default,

and reindex I deleted already all the pub folder and regenerated again, i also set the shop on the production mode.

I also did this:

Open up app/etc/di.xml and find the virtualType name="developerMaterialization" section. In that section you'll find an item name="view_preprocessed" that needs to be modified or deleted.

You can modify it by changing the contents from

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink to Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Delete the files under pub/static to get rid of any existing symlinks. You may want to be careful not to delete the .htaccess file.

I am run of ideas, why the css an js not working. If i inspect the page, i recive 404 for all the css even the files are there.

For example:

I have 404 for this file

http://mysite.hypernode.io/pub/static/version1499347283/frontend/Venustheme/namespace/nl_NL/Ves_BaseWidget/css/styles.css

If i acess this in browser i recive 404 but if i remove version149934728 for link and acessed again like this:

http://mysite.hypernode.io/pub/static/frontend/Venustheme/namespace/nl_NL/Ves_BaseWidget/css/styles.css the files it's accessed

Does anyone know how can i solve this problem?

0

Run following query in database

INSERT INTO `core_config_data` (`scope`, `scope_id`, `path`, `value`) VALUES ('default', 0, 'dev/static/sign', '0');

or if you have already value for that path, then change it from 1 to 0.

Then flush cache and deploy static content as follows.

php bin/magento cache:flush
php bin/magento setup:static-content:deploy en_US nl_NL
  • When i tried to do this i recive this : Duplicate entry 'default-0-dev/static/sign' for key 'CORE_CONFIG_DATA_SCOPE_SCOPE_ID_PATH' – Alin Lupoiu Jul 10 '17 at 13:52
  • There could be permission issues with new server. – Sejal Shah Jul 11 '17 at 10:46
  • It seems you have already that path in database. So change its value from 1 to 0. – Kishan Patadia Jul 11 '17 at 12:17
  • This work for me, i was facing same issue and by changing the value in database as shown in above solution solved my problem, or else u must double check the folder access whether its writable or not. – Kajal Solanki Aug 23 '18 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.