0

Recently we have been experiencing issues when trying to access pages on the back end, the page just doesn't load.

We have tried multiple browsers (IE, Chrome, Firefox, Safari) and this had made no difference. This issue has only started happening in the last couple of days.

I'm relatively new to working with websites and this is the first major issues I've encountered.

5
  • are you get any error logs Jul 7, 2017 at 4:47
  • @Rajkumar.E I am not getting any error logs.
    – Kdiz
    Jul 7, 2017 at 4:58
  • are you reindex, you database, if not run this command php bin/magento indexer:reindex then check it. Jul 7, 2017 at 5:02
  • Is this what you are looking for? main.CRITICAL: exception 'Magento\Framework\Exception\FileSystemException' with message 'Cannot read contents from file "/home/buyprint7/public_html/pub/static/frontend/Smartwave/porto/en_AU/mage/requirejs/mixins.js" Warning!file_get_contents(/home/buyprint7/public_html/pub/static/frontend/Smartwave/porto/en_AU/mage/requirejs/mixins.js): failed to open stream: No such file or directory' in /home/buyprint7/public_html/vendor/magento/framework/Filesystem/Driver/File.php:149
    – Kdiz
    Jul 7, 2017 at 5:30
  • Same like your some controller return with html content, I gest that is error alert.
    – HoangHieu
    Jul 7, 2017 at 12:13

5 Answers 5

1

There are many cases which can result in same issue

First delete follow folders in Magento root:

var/cache
var/di
var/generation
var/view_preprocessed
var/page_cache
var/log
pub/static/adminhtml
pub/static/_requirejs/adminhtml

If you are in development stage then turn on developer mode by applying below mentioned command from Magento CLI:

php bin/magento deploy:mode:set developer

If you are in production mode then run below command in terminal:

php bin\magento deploy:mode:set production
php bin\magento setup:static-content:deploy

Lastly, refresh admin/backend and frontend page

5
  • Thank you @Ananth for your reply. Unfortunately, I'm still experiencing the same issue even after following those steps.
    – Kdiz
    Jul 7, 2017 at 4:30
  • Hi, can you let us know your magento version, OS, version, php version
    – Ananth
    Jul 9, 2017 at 10:06
  • @anath 2.1.7 Current PHP version: 5.6
    – Kdiz
    Jul 10, 2017 at 1:57
  • I think some extension problem is there, can you disable third party extensions and check again (Note: before checking do as my answer)
    – Ananth
    Jul 11, 2017 at 2:53
  • @Kdiz Can we talk on Skype?
    – Ananth
    Jul 11, 2017 at 3:00
0

You files are not accessible in pub folder. So please Put file permission for below folders

root dir >chmod -R 0777 var/ pub/

then reload the page ctrl+R.

1
  • I have done this and I'm still having the same issue
    – Kdiz
    Jul 7, 2017 at 6:18
0

I think you need to create static-content with specific language

clear all in

 <mage-root> rm -rf var/*
 <mage-root> rm -rf pub/static/* (not .htaccess)
 <mage-root> php bin/magento setup:static-content:deploy en_AU
 <mage-root> php bin/magento cache:clean

if you want debug info

 <mage-root> php bin/magento -vv setup:static-content:deploy en_AU

Then Clear Cache, then check it. make sure you need to put right folder and file permission.

Reference: https://github.com/magento/magento2/issues/2065

http://devdocs.magento.com/guides/v2.1/install-gde/prereq/file-system-perms.html

1
  • Hi @Rajkumar .E This didn't resolve the issues. Thank you
    – Kdiz
    Jul 10, 2017 at 1:37
0

You can follow the following steps

1) Delete the "di" folder located in var directory

2) Run this command in project root folder command:cd /yourmagentoroot/bin

3) Then run this command sudo ./magento setup:di:compile

4) Finally give file/directory permissions.

Source : http://blog.trimantra.com/error-magento-2-upgrade-command/

2
  • Unfortunately this didn't fix the issue. Thank you
    – Kdiz
    Jul 10, 2017 at 1:54
  • Okey i will check and provide the best one :) Jul 10, 2017 at 4:39
0

It seems like you're a Windows user. After struggle of weeks I got the solution. I hope it will help you people as well. Please follow the steps:

  1. First of all give permission to your directory of project using

takeown /F C:\xampp\htdocs{your_project_name}

  1. Secondly, Flush the cache

    php bin/magento cache:flush

  2. Then, perform reindexing

    php bin/magento indexer:reindex

  3. Finally, deploy static content and you're done

    php -dmemory_static=6G bin/magento setup:static-content:deploy -f

Use -f in deploying static content if you're in developer mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.