0

I'm running Magento 1.7 on php6.5, which was previously on php5.3.

First problem, Deprecated functionality: iconv_set_encoding(), was solved with this: Magento 1.9, php 5.6 - Use of iconv.internal_encoding is deprecated

Now I've got a new error message:

ini_set(): Cannot find save handler 'memcache'  in /var/www/rkbridal/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php

How to work through this?

1

If you are running a single server, I would just configure sessions to use the file system. In you app/etc/local.xml set session_save to files (see below). If you have the memory on your server setup you could mount the var/session and var/cache to memory using tmpfs. See https://www.prohost.be/magento-tmpfs-ramdrive-varcache-and-varsessions/ for details.

<config>
<global>
    <install>
        <date><![CDATA[Tue, 07 Oct 2014 02:55:25 +0000]]></date>
    </install>
    <disable_local_modules>false</disable_local_modules>
    <resources>
        <db>
            <table_prefix><![CDATA[]]></table_prefix>
        </db>
        <default_setup>
            <connection>
                <host><![CDATA[localhost]]></host>
                <username><![CDATA[root]]></username>
                <password><![CDATA[root]]></password>
                <dbname><![CDATA[magentodb]]></dbname>
                <initStatements><![CDATA[SET NAMES utf8]]></initStatements>
                <model><![CDATA[mysql4]]></model>
                <type><![CDATA[pdo_mysql]]></type>
                <pdoType><![CDATA[]]></pdoType>
                <active>1</active>
            </connection>
        </default_setup>
    </resources>
  <session_save><![CDATA[files]]></session_save>
</global>
</config>
  • Thanks! I have just disabled memcache and session_save in local.xml for local development purposes. – TheKitMurkit Jul 7 '17 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.