1

This is the Image with Problem in which I did not see "image upload" and "Delete" button enter image description here

Our Magento See this button like below image The Magento Actual Output enter image description here

So how can i display this button

Console Shows Error like

Uncaught TypeError: Cannot read property 'description' of undefined
    at Object.Flex.getFlashPlayerVersion (flex.js:164)
    at Object.Flex.checkFlashPlayerVersion (flex.js:46)
    at klass.detectFlashVersion (flex.js:425)
    at klass.initialize (flex.js:200)
    at new klass (prototype.js:101)
    at klass.initialize (flexuploader.js:63)
    at klass (prototype.js:101)
    at eval (eval at <anonymous> (prototype.js:612), <anonymous>:6:56)
    at prototype.js:612
    at prototype.js:865
7
  • try to open in different browser, try to open in chrome Jul 6, 2017 at 13:01
  • I try this already but not shown can you tell me from where this button comes? or some hints if you know
    – Jaimin
    Jul 6, 2017 at 13:02
  • button is coming from /app/design/adminhtml/default/default/template/media/ can you check permission for directory and file skin/adminhtml/default/default/images/ Jul 6, 2017 at 13:10
  • actually this is a static block problem so is it come from media file?
    – Jaimin
    Jul 6, 2017 at 13:13
  • what permission i need. 755 permission is already given
    – Jaimin
    Jul 6, 2017 at 13:18

3 Answers 3

4

I had the same problem, it was browser related. In Chrome: Settings - Advanced Settings - Content Settings - Flash - turn off 'Ask First'.

2
  • or put it in the "allowed" list. ModPagespeed was also causing a issue for me even with ModPagespeedDisallow "/index.php/admin"
    – Misho
    Mar 8, 2018 at 1:38
  • no longer an option in chrome, you have to fallback on firefox Mar 21, 2019 at 16:35
1

It's cause browser disabling flash last time. You can try to use some existing solution, like enter link description here Or upgrade magento to latest version, they already fixed it there

0

Have you installed an admin theme? The styling looks different, maybe that theme is conflicting or has bugs?

Try removing the admin theme and see if the problem persists.

1
  • yes i disable my theme and still there is a problem there is a flex jquery missing problem
    – Jaimin
    Jul 7, 2017 at 5:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.