0

I've installed Magento 2.1 Community Edition through composer (there was just an alert about some utility). I use Ubuntu 16.04, PHP 5.6, Apache2, MYSQL.

After installing I went to the admin panel but got just -

Not Found

The requested URL /admin_admin was not found on this server.

Apache/2.4.18 (Ubuntu) Server at magento.support.loc Port 80

Site settings in apache

<Directory home/ivan/sites/magento> Options Indexes FollowSymLinks AllowOverride All Require all granted </Directory>

When I load my front page, I just see HTML markup and no one font or style loading. They are in not existing folders like

http://magento.loc/pub/static/version1499045285/frontend/Magento/luma/en_US/css/styles-l.css

There is no version1499045285 folder.

What i did wrong? Maybe i did not activate some Apache mods?

1

1- Make sure mod_rewrite is enabled on the server.

2 -After installation if css is not loading then please run deploy command from the root of magento

php bin/magento setup:static-content:deploy

3- Set permission var pub/ static folder to 777

chmod -R 777 var pub/static
1

This issue because of AllowOverride All is not set and sudo a2enmod rewrite is not enable

<Directory home/ivan/sites/magento>
    Options Indexes FollowSymLinks 
    AllowOverride All
    Require all granted
  </Directory>

Deploy:

php bin/magento setup:static-content:deploy

Permission set:

chmod -R 777 var pub/static
  • It's set. Rewrite mod enabled. Read the topic please. – Bitrix24 Jul 6 '17 at 14:13
  • I updated the answer – Rama Chandran M Jul 6 '17 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.