0

I am trying to get an attribute to the filter in my webshop. I have tried several things in the admin panel, but nothing seems to work.

At the moment there are two attributes in it, profile color and height, but i also want width in it.

The attribute is made with the correct settings. So what now?

  • Exactly what 'things' did you try in the admin panel? A bit more info is needed. see here magentocommerce.com/knowledge-base/entry/… and youtube.com/watch?v=_PQhITHhWUk and remember to flush your cache and disable compilation – tecjam Apr 10 '14 at 9:02
  • Basicly the things the two answers told me to do + I added the attribute in the right attribute set. – Reijer Apr 10 '14 at 9:16
  • Do products using this filter exist, are activated etc? Otherwise the filter won't show; also, did you clear the cache and reindex? – simonthesorcerer Apr 11 '14 at 19:40
1

Edit the attribute in the backend and set the value for Use In Layered Navigation to Filterable (with results) or Filterable (no results). Save and rebuild your indexes.
Do the same for Use In Search Results Layered Navigation.

But keep in mind that only dropdown, multiple select and price attributes can be displayed in the filters.

  • This was already the case. I copied the settings of the "height" attribute. – Reijer Apr 10 '14 at 9:12
0

Login to admin panel and goto catalog-> attributes -> manage attributes

and click on addattributes button In add attributes properties tab add your attribute code and set all you want necessary fields. For your attribute label or option set under Manage label tab. if you want to show this attributes on product view page for filter Visible on Product View Page on Front-end set Yes if you created your attribute set for your product select it while adding product.

  • I had this done already, still didn't work. Not sure what you mean with " if you created your attribute set for your product select it while adding product." though. – Reijer Apr 10 '14 at 9:11
  • Do you created attribute set? – vitts Apr 10 '14 at 9:21
  • It was already there. I'm working on a website that already existed. My assignment was to delete one attribute from the filter, and add a different one. – Reijer Apr 10 '14 at 9:23
  • For that goto->attributes->manage attribute sets-> select your attribute set you used. for adding new one you see your created attribute under Unassigned Attributes section add it. – vitts Apr 10 '14 at 9:33
  • I've also done that... that's the reason i came here. (Yes I realize I should've came with a more detailed question.) Also, when i re-add the attribute that i deleted from that set (dragged it to the Unassigned Attributes), nothing happens. – Reijer Apr 10 '14 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.