0

I have finally been able to install my theme, all the files and the proper commands have all been run. I have tried clearing caches and running the php bin/magento setup:upgrade doesnt help. When I login to the cpanel I see my theme in there and it is set to 0. I have tried everything but when I go to content>design>configuration and select edit on the current theme. My new theme is not listed as an option to select. I have put the store in developer mode as well. Below are my files:

<theme xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Config/etc/theme.xsd">
<title>CyberMark Sparklingearth</title>
<parent>Magento/blank</parent>
<media>
    <preview_image>media/preview.jpg</preview_image>
</media>
</theme>



<?php
/**
 * Copyright © 2013-2017 Magento, Inc. All rights reserved.
 * See COPYING.txt for license details.
 */

\Magento\Framework\Component\ComponentRegistrar::register(
\Magento\Framework\Component\ComponentRegistrar::THEME,
'frontend/CyberMark/sparklingearth',
__DIR__
);



{
"name": "magento/theme-frontend-sparklingearth",
"description": "N/A",
"require": {
    "php": "~5.6.5|7.0.2|7.0.4|~7.0.6",
    "magento/theme-frontend-blank": "100.1.*",
    "magento/framework": "100.1.*"
},
"type": "magento2-theme",
"version": "100.1.6",
"license": [
    "OSL-3.0",
    "AFL-3.0"
],
"autoload": {
    "files": [
        "registration.php"
    ]
}
}

1 Answer 1

0

you need to change this "name": "magento/theme-frontend-sparklingearth" line

with "name": "cybermark/sparklingearth" into composer.json

4
  • I did what you suggested. However after applying the following commands php bin/magento setup:upgrade –keep-generated php bin/magento setup:static-content:deploy php bin/magento cache:clean php bin/magento cache:flush It is still not showing up in my dropdown of available choices. I need to get this figured out. Any other thoughts? Jun 30, 2017 at 23:36
  • Go into given below link mageplaza.com/kb/how-to-create-magento-2-theme.html and match your theme & folder structure and if still you are not get solution, then make your vendor name & theme name in small letter.
    – Brijesh
    Jul 1, 2017 at 15:25
  • I have followed your advice and done these things. Please help its not showing up still. Jul 3, 2017 at 16:39
  • please make sure that project deploy mode should be developer mode, clear var/cache, pub/static, var/generation and then deploy the content & check then. If still it's not working, then check your log into exception.log into var/log folder
    – Brijesh
    Jul 4, 2017 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.