I have tried to add some existing attributes to the layered navigation filter options. I have set the attribute to be used in layered navi and set filterable (with results).

enter image description here

The Filter is displayed, but it doesn't 'stick' - unlike the other filters available and it does not limit the products in the category view.

enter image description here

I have tried re-indexing, deleting locks, re-indexing again and still the same behaviour.

I have checked the logs but nothing is being logged.

Has anyone had this issue before and knows how to fix any of the above? Any help would be greatly appreciated.

Running Magento CE 1.8.1 with the default navigation (no plug in)

  • Ok, so I have tried to disable the cache, and then these new filters work and 'stick' - with 'stick' I mean they are shown as active and are removable with the x next to it and the products are filtered accordingly. When I re-enable the cache these filters are not working.
    – tecjam
    Apr 9, 2014 at 14:21
  • On another note, I have compilation disabled. I have gone through the cache options and the problem with the non-working filters seems to be the FPC Caching - Lesti FPC. It seems as if I need to add the url parameter for this filter to the system_fpc_uri_params field in config -> advanced -> system
    – tecjam
    Apr 9, 2014 at 14:31

1 Answer 1


The answer is: It's the fault of the Lesti Full Page Cache - Lesti FPC Module.

In System -> Configuration -> Advanced -> System the new URI Parameters for the filters must be added!

I hadn't thought of that and actually thought it would add these or any new filters automatically - but it does not.

As for the '38-FR40' Problem .... I may ask that in a seperate question to avoid confusion with the title.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.