0

I'm working on a Magento 2 template, based on Luma and I've run into an issue with the Contact Us page.

The content of the CMS block (contact-us-info) isn't showing up in my template. All I get is the contactform on the right side of the page. See the partial screenshot:

Contact page without content, custom template

When I activated the Luma template to check, lo and behold, there it was, neatly above the contact form...

Contact page with content, Luma template

Can anybody shed some light on the issue? It's probably something very small and stupid...

0

Okay, never mind. As expected, it was a very small thing which I should have known... The block is called by a widget, which, in turn, is linked to the template. Duh! Sorry to bother you guys!

I feel really stupid now...

0

@MooiMentha No question however small it may be is stupid. However, the answer you gave doesn't help anyone coming after you solve the issue as your answer is not detailed enough. Please try to provide a clear and detailed answer in the future.

I had the same issue and the problem comes from the fact that all the widgets in the Luma template are linked to the Magento Luma template as opposed to the Magento Blank template which we are using.

To correct this a new widget needs to be created which is identical to the Contact us info except for the fact that is linked to the Magento Blank Design Package/Theme.

You can find a similar solution here

I am however experiencing issues with the fonts of the Contact us info block which are larger than they should be if anyone can comment on how to resolve this. I will revert if I manage to find the reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.