4

I am trying to install Fris Social share in my Magento 1.9.3 store.

I am getting the following error after installation:

Fatal error: Class 'Fris_Socialbuttons_Helper_Data' not found in D:\xampp\htdocs\magento\app\Mage.php on line 547

I have disabled Compilation in admin>system>tool>compilation its working fine, but when I enable Compilation, it shows above error.

Following code in app\code\local\Fris\Socialbuttons\etc\config.xml

 <?xml version="1.0" encoding="UTF-8"?>

<config>
    <modules>
        <Fris_Socialbuttons>
            <version>1.0.2</version>
        </Fris_Socialbuttons>
    </modules>

    <global>
        <blocks>
            <fris_socialbuttons>
                <class>Fris_Socialbuttons_Block</class>
            </fris_socialbuttons>
        </blocks>
        <helpers>
            <fris_socialbuttons>
                <class>Fris_Socialbuttons_Helper</class>
            </fris_socialbuttons>
        </helpers>
    </global>

    <frontend>
        <layout>
            <updates>
                <socialbuttons module="Fris_Socialbuttons">
                    <file>fris/socialbuttons/socialbuttons.xml</file>
                </socialbuttons>
            </updates>
        </layout>
    </frontend>

    <default>
        <design>
            <socialbuttons module="fris_socialbuttons">
                <font_icon_facebook>fa fa-facebook</font_icon_facebook>
                <font_icon_google_plus>fa fa-google-plus</font_icon_google_plus>
                <font_icon_linkedin>fa fa-linkedin</font_icon_linkedin>
                <font_icon_pinterest>fa fa-pinterest</font_icon_pinterest>
                <font_icon_twitter>fa fa-twitter</font_icon_twitter>
                <font_icon_twitter_follow></font_icon_twitter_follow>
                <twitter_handle></twitter_handle>
                <button_container_style></button_container_style>
                <button_style></button_style>
            </socialbuttons>
        </design>
    </default>

</config>

app\code\local\Fris\Socialbuttons\Helper\Data.php

class Fris_Socialbuttons_Helper_Data extends Mage_Core_Helper_Abstract
{
}

How to fix this error?

Thanks in advance

  • have you defined <helpers> inside global tag? Show your full config.xml code – Priyank Jun 28 '17 at 5:57
  • @userpk : Thank you for your reply am updated the code – Madhumitha Jun 28 '17 at 5:59
  • After the installation of this module, did you re-run the compile? – Pavan Kumar Jun 28 '17 at 6:02
  • @PavanKumar How can i re-run compile – Madhumitha Jun 28 '17 at 6:03
  • through admin, system-tools-compile-rerun. I m not sure about the path. But, if you add any new module when the compilation is enable, then u need to rerun the compile – Pavan Kumar Jun 28 '17 at 6:14
1

Here is your full xml like.

<?xml version="1.0" encoding="UTF-8"?>
<config>
    <modules>
        <Fris_Socialbuttons>
            <version>1.0.2</version>
        </Fris_Socialbuttons>
    </modules>
    <global>
        <blocks>
            <socialbuttons>
                <class>Fris_Socialbuttons_Block</class>
            </socialbuttons>
        </blocks>
        <helpers>
            <socialbuttons>
                <class>Fris_Socialbuttons_Helper</class>
            </socialbuttons>
        </helpers>
    </global>
    <frontend>
        <layout>
            <updates>
                <socialbuttons module="socialbuttons">
                    <file>fris/socialbuttons/socialbuttons.xml</file>
                </socialbuttons>
            </updates>
        </layout>
    </frontend>
    <default>
        <design>
            <socialbuttons module="socialbuttons">
                <font_icon_facebook>fa fa-facebook</font_icon_facebook>
                <font_icon_google_plus>fa fa-google-plus</font_icon_google_plus>
                <font_icon_linkedin>fa fa-linkedin</font_icon_linkedin>
                <font_icon_pinterest>fa fa-pinterest</font_icon_pinterest>
                <font_icon_twitter>fa fa-twitter</font_icon_twitter>
                <font_icon_twitter_follow></font_icon_twitter_follow>
                <twitter_handle></twitter_handle>
                <button_container_style></button_container_style>
                <button_style></button_style>
            </socialbuttons>
        </design>
    </default>
</config>
  • Sorry Aman Alam not working – Madhumitha Jun 28 '17 at 6:04
  • i have just posted full xml you should try that after updating xml don't forget to clear caching – Aman Alam Jun 28 '17 at 6:09
  • Same error sorry – Madhumitha Jun 28 '17 at 6:14
  • Do you have compiler enable? – Aman Alam Jun 28 '17 at 6:24
  • Yes i did...... – Madhumitha Jun 28 '17 at 6:34
1

try changing this part of your code

<socialbuttons module="fris_socialbuttons">

Try changing it to your helper alias:

    <layout>
        <updates>
            <socialbuttons module="fris_socialbuttons">
                <file>fris/socialbuttons/socialbuttons.xml</file>
            </socialbuttons>
        </updates>
    </layout>
  • Sorry not working – Madhumitha Jun 28 '17 at 6:07
  • AM update your code and clear cache in var\cache folder and run it showing same error – Madhumitha Jun 28 '17 at 6:08
  • Can you please update your full code – Madhumitha Jun 28 '17 at 6:09
  • 1
    disable and re-compile again – Priyank Jun 28 '17 at 6:09
  • 1
    Okay just a min – Madhumitha Jun 28 '17 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.