0

I've installed successfully the Magento-CE.2.1.7 via Setup Wizard installation in Ubuntu16.04 Apache2.4.18 PHP 7.0.18, but cannot access the Magento Admin in the web browser. I've tried command a2enmod rewrite or a2enmod access_compat, but it does not solve the issue.

when I use the command php bin/magento cache:status , get the errors below even I have enable openssl extension extension=php_openssl.dll and extension_dir = "ext" in the file /etc/php/7.0/cli/php.ini :

The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your own risk, by setting the 'disable-tls' option to true.#0 /var/www/html/vendor/composer/composer/src/Composer/Factory.php(306): Composer\Factory::createRemoteFilesystem(Object(Composer\IO\BufferIO), Object(Composer\Config))
#1 /var/www/html/vendor/composer/composer/src/Composer/Factory.php(532): Composer\Factory->createComposer(Object(Composer\IO\BufferIO), Array, false)
#2 /var/www/html/vendor/magento/framework/Composer/ComposerFactory.php(47): Composer\Factory::create(Object(Composer\IO\BufferIO), '/var/www/html/...')
#3 /var/www/html/vendor/magento/framework/Composer/ComposerInformation.php(362): Magento\Framework\Composer\ComposerFactory->create()
#4 /var/www/html/vendor/magento/framework/Composer/ComposerInformation.php(375): Magento\Framework\Composer\ComposerInformation->getComposer()
#5 /var/www/html/vendor/magento/framework/Composer/ComposerInformation.php(242): Magento\Framework\Composer\ComposerInformation->getLocker()
#6 /var/www/html/vendor/magento/framework/App/ProductMetadata.php(104): Magento\Framework\Composer\ComposerInformation->getSystemPackages()
#7 /var/www/html/vendor/magento/framework/App/ProductMetadata.php(65): Magento\Framework\App\ProductMetadata->getSystemPackageVersion()
#8 /var/www/html/vendor/magento/framework/Console/Cli.php(81): Magento\Framework\App\ProductMetadata->getVersion()
#9 /var/www/html/bin/magento(22): Magento\Framework\Console\Cli->__construct('Magento CLI')
#10 {main}


Fatal error: Uncaught Error: Class 'Cli' not found in /var/www/html/bin/magento:31
Stack trace:
#0 {main}
  thrown in /var/www/html/bin/magento on line 31

I have googled the issues , but no luck. Would you please help.

0

Check

php -i | grep 'Configuration File'

to make sure you are editing the correct ini file.

0

I run the command: php -i | grep 'Configuration File' got the output:

Configuration File (php.ini) Path => /usr/local/lib

Loaded Configuration File => (none)

I've checked the path of configuration File (php.ini) Path: /etc/php/7.0/apache2

How I can change the configuration file path? Please advise. Thanks

  • I installed to versions of PHP. I reinstall PHP and the problem is solved. Thanks Paj for reminding me to check the Configuration File – C. Nguyen Jul 9 '17 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.