-1

Migrated Magento from one server to another and update PHP from 5.4 to PHP 7.0. I have image inside a product page, but don't have images on the main page

enter image description here

Uncaught TypeError: Cannot read property 'fn' of undefined
/:100 Uncaught SyntaxError: Unexpected token ,
 Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_office_001_t.resized_1_1_2.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_office_001_t.resized_1_1_1_1.png Failed to load resource: the server responded with a status of 404 (Not Found)
https://xenergo.net/ledstore/ntend/default/jm_flannel/images/currency/CZK.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_office_001_t.resized_1_1.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/ntend/default/jm_flannel/images/currency/NOK.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_uliczna_001_tdziwna_1.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/ntend/default/jm_flannel/images/currency/GBP.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/u/n/untitled_1_wince__2_1_1_1.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/u/n/untitled_1_wince__2_2.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/u/n/untitled_1_wince__2_1_1.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/u/n/untitled_1_wince__2_1.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/u/n/untitled_1_wince__2_1_1_2_1.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/2/x/2x7w_600mm.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/images/catalog/product/placeholder/thumbnail.jpg Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_office_001_t.resized_3.png Failed to load resource: the server responded with a status of 404 (Not Found)
ledstore/ntend/default/jm_flannel/images/currency/CHF.png Failed to load resource: the server responded with a status of 404 (Not Found)
11
  • Try to inspect those images using your browser's web developer tool. Check the images URL's and post the the URL example here. Also, try to open some product from the list in the admin panel and click "Save" just to resave the product. Check if the image appears on the main page after. Jun 23, 2017 at 11:07
  • did you reindex after import the images?
    – user51361
    Jun 23, 2017 at 11:29
  • Yes I'am reindex (twice) system - index managment - reindex all Jun 23, 2017 at 11:49
  • Also I try resave image and add new image its didnt help me :( Jun 23, 2017 at 11:51
  • 1
    If you who found the answer, please answer your question and accept it.
    – PЯINCƎ
    Jul 8, 2017 at 21:40

1 Answer 1

-1

In admin panel Flush Catalog Images Cache from

admin > Sytem > Cache Management > Flush Catalog Images Cache

also check if your media has appropriate permission. The default permission for magento are as below

find . -type f -exec chmod 400 {} \;
find . -type d -exec chmod 500 {} \; 
find var/ -type f -exec chmod 600 {} \; 
find media/ -type f -exec chmod 600 {} \;
find var/ -type d -exec chmod 700 {} \; 
find media/ -type d -exec chmod 700 {} \;
chmod 700 includes
chmod 600 includes/config.php
9
  • I Flush Catalog Images Cache but its didnt help me Jun 23, 2017 at 12:56
  • <your magento root dir>/media/catalog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43bc35/l/a/lampa_office_001_t.resized_1_1_2.png have you does image exists in above path.
    – Priyank
    Jun 23, 2017 at 12:58
  • Yes, I have an images there. Jun 23, 2017 at 13:32
  • But i found that when I used "inspection " I see a problem with link: talog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43b must be catalog/product/cache/1/thumbnail/180x180/8e014dfe9f6c69941cf952d49a43b Jun 23, 2017 at 13:35
  • Which skript i mast edit that to solve the problem? Jun 23, 2017 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.