3

My issue is that I can't login to the admin panel, I know that this is already asked, and I have tried:

  1. Clear cache and sessions,browser cookies.
  2. web/cookie/cookie_domain and web/cookie/cookie_path clear in the table core_config_data
  3. i will check the session path its correct

but still same error.

4

Possible causes :

  • Local computer time vs. server time mismatch, causing instant cookie invalidation. Make sure your server time is correct.

  • Incorrect permissions on var/session, preventing session files from being saved

  • Incorrect configuration of database/redis/other session storage, preventing saving of session values

  • A module is instantiating sessions to early, preventing the correct session names from being set

  • You're a developer using multiple URLs and have multiple cookie domains

  • Another developer has somehow modified app\code\core\Mage\Core\Model\Session\Abstract\Varien.php, creating a hard to track down bug

  • The cookie domain in System -> Configuration -> Web -> Session Cookie Management doesn't match the actual site domain.

  • You're using the localhost as your server domain, and using a version of webkit that has trouble/bugs setting cookies for localhost in some situations.

The short term fix is to just delete your cookie for the domain. That's often enough to solve the problem. If it persists, figure out which of the above reasons is the reason for your error.

  • Changing 'Use HTTP only' to 'No' in 'System->Configuration->Web->Session Cookies Management' of the 'Web' settings.

Reference

  • I am new to magento.Explain what i need to do @Prince – Ravi Kumar Jun 22 '17 at 12:30
  • Where have you this issue ? – PЯINCƏ Jun 22 '17 at 12:33
  • During admin login i have this issue – Ravi Kumar Jun 22 '17 at 12:39
  • are you using Chrome browser ? – PЯINCƏ Jun 22 '17 at 12:46
  • Yes and also Mozilla – Ravi Kumar Jun 22 '17 at 12:50
2

New versions of Magento like 1.9 require to have in phtml file

<input type="hidden" name="form_key" value="<?php echo Mage::getSingleton('core/session')->getFormKey() ?>" /> 

to prevent CSRF (Cross-Site Request Forgery) attacks.

2

Instant solved problem with:

    $ n98 config:delete web/cookie/cookie_domain
     // make sure dir in the system and correct permission tmp/session
    <session_save><![CDATA[files]]></session_save>
    <session_save_path><![CDATA[/tmp/session]]></session_save_path>

Greetings from Posadas 3300, Argentina

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.