0

I am currently trying to figure out why paypal is not working properly.

I found this error in the logs.

2017-06-22T02:18:31+00:00 DEBUG (7): Array (
[url] => https://api-3t.paypal.com/nvp
[getPalDetails] => Array
    (
        [METHOD] => getPalDetails
        [VERSION] => 94.0
        [USER] => ****
        [PWD] => ****
        [SIGNATURE] => ****
        [BUTTONSOURCE] => IWD_SI_Other_OnePage
    )

[response] => Array
    (
        [PAL] => XXXXXXXXXX (-->Merchant ID)
        [LOCALE] => en_AU
        [TIMESTAMP] => 2017-06-22T02:18:31Z
        [CORRELATIONID] => 182c8e5d91387
        [ACK] => Success
        [VERSION] => 94.0
        [BUILD] => 29297572
    )

[__pid] => 7545
)

It states a success but is recorded as a bug.

What do I do to fix this?

I am using magento 1.9.3.3 and Paypal Website Payments Standard (Includes Express Checkout)

The checkout allows guest checkout.

Enable SSL verification set to No.

4
  • Does it turn to any PHP exception error pages? Or the flow goes properly? Debug log does NOT always mean the module have bugs.
    – PY Yick
    Jun 22, 2017 at 4:50
  • It continues on the flow. But this bugs me. (sorry for the pun)
    – fja3omega
    Jun 22, 2017 at 5:25
  • Are you in developer mode? Check the setting on System->Configuration ->Payment Methods (Basic Settings - PayPal Express Checkout)
    – PY Yick
    Jun 22, 2017 at 5:31
  • @PYYick I have debug mode active due to my client telling me that Paypal orders are not being registered. I don't know if this is the cause though.
    – fja3omega
    Jun 22, 2017 at 5:45

1 Answer 1

0

First of all, it's NOT an error.

As you said that the flow is not interrupted, so I'm sure it's just a setting issue. You turned on the debug mode on Paypal so var/log/debug.log keep printing the data from Paypal. If this debug log caused you some annoyances, you can turn it off by System->Configuration ->Payment Methods (Basic Settings - PayPal Express Checkout)->Off.

4
  • I turned on the logs to see where the error in paypal payments orders not getting registered is being generated. Maybe it is a false flag. I am currently investigating whether it may be due to the chron jobs.
    – fja3omega
    Jun 22, 2017 at 7:38
  • Surely not related to CRON job. As I stated before, you're NOT encountering any problems. The debug log generates every time you use Paypal unless you turn off this setting.
    – PY Yick
    Jun 22, 2017 at 7:43
  • So I assume I can safely ignore that success debug. I just thought it was related to the paypal orders not being recorded error and if I fixed it then the paypal payment order would record properly.
    – fja3omega
    Jun 22, 2017 at 7:56
  • Hurray, you got my point! You can move on to other tasks.
    – PY Yick
    Jun 22, 2017 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.