4

I have a configurable product and i want this product to stop appearing in the frontend. I have already disabled the product and set visibility to 'Not visible individually' but still frontend showing this product.

Another thing i want to share is, when i disable the product, it still shows as enabled in catalog grid but when i open that product, it shows as disabled.

  • did you reabuild the indexes? – Marius Jun 19 '17 at 19:52
  • yes i have already reindex it. – umair ayub Jun 19 '17 at 19:56
4

Fixed. Visibility scope was set to 'store view' level and i was not changing the attribute for my required 'store view'. After choosing the appropriate 'store view' and setting visibility attribute as 'Not visible individually', product does not appear in the frontend.

| improve this answer | |
  • Where to find Visibility Scope in Magento 2.3 product? I only see a "Visibility Catalog,Search" but if the products not enabled... it shouldn't be shown! – Liam Mitchell Jun 6 '19 at 1:31
  • @LiamMitchell I'm on 2.2.5. He means the first thing you see under the product title when you open a product in Amin. It says: "Store View All Store View" with an arrow for a drop down. In the drop-down, you see the scope until the name of your store. So in my case, I always edit in All Store View, but it seems one product was edited in MyStoreView, and I was disabling it from All Store View while the product in MyStoreView was enabled and overriding the default settings. The product was even showing in upselling products "We found other products you might like!" – Mohammed Joraid Jun 23 '19 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.