1

Searching is not working for new added products, though it's working for old products.

Any ideas?

  • can you reindex once , atleast for search index index by system > index Management..... – Baby in Magento Jun 16 '17 at 10:40
  • Done, still not working. – Greg Jun 16 '17 at 10:50
  • is products visible if you open by url, means sitename.com/product-url.html – Baby in Magento Jun 16 '17 at 10:52
  • Yes. I can find it it category too. I just can't search for it. – Greg Jun 16 '17 at 10:53
  • 1
    @BabyinMagento I will do! Thanks a lot for you help and interest! Lets see what they have to say :) – Greg Jun 16 '17 at 11:31
4

You gave to select Catalog,Search option in Visibility field. Thats reason new added products are not displaying in search result.

enter image description here

  • Hi, thank you for your interest. I had a look and it is already catalog,search in visibility search. – Greg Jun 16 '17 at 10:48
  • ok. try by clean,refresh cache and reindexing – Jai Jun 16 '17 at 10:52
  • Already done. Still not working. I can find the product by looking into the category but search is not working. – Greg Jun 16 '17 at 10:54
  • 1
    Ok. Duplicate any OLD product and rename that. Check if that loading in search? In this way you can compare setting as well. – Jai Jun 16 '17 at 10:58
  • I have duplicated old iteam and renamed, reindexed and cleared cache but it is still not displaying so I don't think it is related to the settings. – Greg Jun 16 '17 at 11:05
1

I found where the issue was. As I am using a 3-rd party extension (Sphinx search by Mirasvit) the configuration was not properly set. Previous employer made really difficult configuration where search engine was set to be hosted on a external server, not maintained by anyone. Changing it to build in search engine solve the issue.

0

You need to confirm following points with your new products according to Store View,

Status = Enabled

Visibility = Catalog, Search

Stock Availability = In Stock

Qty = Greater than 0

Categories = Category associated

And also make sure same setting applied for Website and Store view you can check through the Choose Store View option.

Hope it will help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.