0

I have problem with a Magento site I haven't been able to solve Googling my way around. On I have 3 store views (NL, EN, DE). When on a product page and I want to switch language sometimes I get a 404 error but other times the product switches correctly to the right language. I have observed the URL behavior closely and came up with this:

In case of a successful switch the URL changes from for example www.example.com/supplies_nl/product.html to www.example.com/supplies_en/product.html?___from_store=supplies_en

However in other cases when the switch in unsuccessful the URL is changed from www.example.com/supplies_nl/product.html to www.example.com/supplies_nl/product.html?___from_store=supplies_en resulting in a 404 error.

Has anyone encountered such behavior and what can be done to have this working correctly al the time?

Using Magento 1.8.0

  • This can't be right. In your first example it should be ___from_store=supplies_nl and in your second ___from_store=supplies_en plus in your second example clearly there is no storeview change – Yiorgos Moschovitis Apr 6 '14 at 12:50
  • Exactly, that is the funny thing. Some products have a store view change and some don't. Could it be something on the product level that needs adjusting? – Badger Apr 6 '14 at 13:39
  • Any Full Page Cache in the mix here and if so, did you holepunch the store switcher? – Melvyn Apr 6 '14 at 14:19
  • I cleaned all cache so that won't contribute to the problem. What do you mean by holepunching the store switcher? – Badger Apr 6 '14 at 20:28
1

I solved this problem on my page by just adding the store where the link should go to then end of the url, like: www.example.com/supplies_nl/product.html to www.example.com/supplies_nl/product.html?___store=english Then it directs to the correct store

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.