0

I am new to M2, and just adding a new module to a local devbox environment using PhpStorm IDE. I've created the module several ways, rather, several modules, each a different way:

Each time, after I create the module I run:

bin/magento module:status

The module appears as a disabled module, great!

I run: bin/magento module:enable Newvendor_Newmodule

If I rerun module:status it now appears as enabled

I run: bin/magento setup:upgrade

So far so good, but when I look in admin Stores -> Configuration -> Advanced -> Advanced the module is NOT in the list... what?

I have cleared cache (several times), disabled the modules, re-enabled them, created new ones... I cannot figure out why they do not appear in admin, but the magento CI "sees" them?

I noticed this while I was trying to debug a simple M2 Frontend Controller Tutorial from Alan Storm. It seems like I must be doing something wrong, but I'm not sure what?

Example of Module contents (inside of app/code/Vendor/Testmodule/)

registration.php

<?php
\Magento\Framework\Component\ComponentRegistrar::register(
\Magento\Framework\Component\ComponentRegistrar::MODULE,
'Vendor_Testmodule',
__DIR__
);

etc/module.xml

<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
<module name="Vendor_Testmodule" setup_version="0.0.1" >
</module>

0

Finally realized what was causing this issue... it is sync related and is documented in this devbox issue https://github.com/magento/magento2devbox-web/issues/79

I tried the solution by @raybogman and that resolved it. I did have to clean out the other files in the .unison directory before I made the watch = false change (don't delete the .prf file)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.