0

This question already has an answer here:

I have successfully installed Magento 2 on my xampp. But when I'm trying to get into the Admin section or see the front-end, then it is coming broken.

I have tried to fix the path issue but its of no use. Dashboard section pretends to load and keeps so, but never loads. The css and js seem's to be broken for the backend and frontend section.

marked as duplicate by Ben Crook, liyakat, benmarks Jun 17 '17 at 16:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0
  • Delete everything under /pub/static folder except .htaccess file.
  • Open terminal and run following commands:

cd [magento_root_folder]

php bin/magento setup:static-content:deploy

  • Remove /var/cache and /var/page_cache folders.
  • Reload page and check.
  • I am using Magento 2.3, if try to run : php bin/magento setup:static-content:deploy the message like Magento supports 7.0.2, 7.0.4, and 7.0.6 or later. Please read devdocs.ma gento.com/guides/v2.2/install-gde/system-requirements.html. My PHP ver 7.2.10 – zus Dec 7 '18 at 6:56
  • @zus, the answer posted is more than 1.5 years old. Please specify in detail, what do you want to say? – Mohit Kumar Arora Dec 7 '18 at 7:48
  • Really thanks for your response, my issue magento.stackexchange.com/q/252069/57334 i am working with that. – zus Dec 7 '18 at 7:53
  • Magento 2.3 installation error : snag.gy/oShfYR.jpg How can i solve this error? @Mohit Kumar Arora – zus Dec 7 '18 at 8:11
  • 1
    You need to grant 777 permission to app/etc/env.php file. – Mohit Kumar Arora Dec 7 '18 at 9:25
0
  1. Add path = 'dev/static/sign' and value = 0 on the core_config_data table
  2. Run in command prompt - sudo chmod -R 777 pub/static var/generation var/cache var
  3. php bin/magento setup:upgrade
  4. php bin/magento setup:static-content:deploy
  5. php bin/magento cache:clean

Not the answer you're looking for? Browse other questions tagged or ask your own question.