0

I have a Magento issue. I have moved everything to a different server, and all seems to work fine - but I can not get the "print PDF invoice" or "Packingslip" option in the order section to work. It just shows a blank page when I try. What could be the problem here?

Thanks!

  • try turning on logging and see if there is anything written into var/logs/system.log – David Manners Apr 4 '14 at 19:33
  • your php version? look for this question magento.stackexchange.com/questions/9721/… – Mufaddal Apr 5 '14 at 7:07
  • Hi! Thanks so much for your responses. @DavidManners - I have logging turned on, and nothing is listed in system.log relating to this. – lisali Apr 5 '14 at 10:27
  • @Mufaddal - I had a look at that and tried changing the file in question, it did not work. Sometimes I'll just get a blank page, and sometimes it will say "There are no printable documents related to selected orders". Odd. Any other ideas? Thanks! – lisali Apr 5 '14 at 10:29
  • Compilation on? – Mufaddal Apr 5 '14 at 10:32
2

as user2694249 said correctly, the problem is a missing backwards compatibility of magento relative to php 5.3/4

The "bug" is already fixed in the newer Zend_Framework 1 versions, but magento has old versions shipped with it.

The bug is fixed with a patch, magento offers. A EE fix is accessable via your internal account area.

1

Here's the solution to the problem described above:

Open up: /lib/Zend/Pdf/FileParserDataSource.php and comment out:

//abstract public function __construct();
//abstract public function __destruct();

Taken from: http://www.pcwired.com/2013/09/my-magento-on-php-5-4-x-fixes

This is caused by a compatibility issue with PHP 5.4.

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.