2

I have launched a new Magento site. A simple CMS page is config as default home page. I have added the meta keywords and descriptions in that CMS page.

But the home page not indexed in Google search. I can't find the exact issues. I hope someone can guide me with a solution it would be appreciated.

1
  • Did you ever figure out the solution to this issue? I'm reviewing my site and I'm finding that the homepage is not in the sitemap.xml. Maybe that's my issue, but it's almost a pure stock Magento so I'm not sure of the cause.
    – Rob
    Commented Jun 11, 2018 at 1:57

2 Answers 2

4

You can configure the option by following below path in Magento 2 admin. Stores -> Configuration -> General (Left side) -> Design (section) -> Search Engine Robots -> Default Robots (Select)-> Select

1. INDEX, FOLLOW

2. NOINDEX, FOLLOW

3. INDEX, NOFOLLOW

4. NOINDEX, NOFOLLOW

Save the configuration as you need. clean and flush cache. You need to select option [1]. It will work.

5
  • Its already selected as INDEX, FOLLOW
    – saravankg
    Commented Jun 14, 2017 at 9:05
  • Check answer from @Rama Chandarn and look if you have sitemap.xml. Also update link of sitemap in robot.txt. You can update robot.txt in admin.
    – Jarnail S
    Commented Jun 14, 2017 at 9:15
  • Sitemap url already specified in robot.txt file
    – saravankg
    Commented Jun 14, 2017 at 10:12
  • like example.com/sitemap.xml
    – saravankg
    Commented Jun 14, 2017 at 10:14
  • yes and you can create it from admin. You can create from ADMIN -> MARKETING -> Site Map (under SEO & SEARCH)
    – Jarnail S
    Commented Jun 14, 2017 at 10:19
1

It may cause different scenario. Please check the link home page not indexed with google search

  1. Your site Don’t Have a sitemap.xml
  2. Your site Have Crawl Errors check in webmaster tool. Webmaster Tools → Select your site, → Click on “Crawl” → Click on “Crawl Errors”
  3. Also check your Magento frontend meta tag index.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.