0

I made a custom theme with luma as my parent theme. Somehow it's only showing the icons of the blank theme and not the one of luma.

Do I need to copy any fonts or declare them in my custom theme?

<theme xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Config/etc/theme.xsd">
  <title>My Theme</title>
  <parent>Magento/luma</parent>
</theme>

Any ideas?

0

I not sure about customise in your layout of your theme.

rm -r var/view_processed/* pub/static/frontend/*
php bin/magento setup:static-content:deploy
php bin/magento cache:flush

If eveything works your theme should be extend all assets from luma. If you use grunt you can deploy theme again

0

I got it. I had the following structure for my theme:

- web
-- css 
--- source
---- variables
----- _globals.less
---- _buttonset.less
---- _footer.less
---- _header.less
---- _navigation_extend.less
---- _productiongrid.less
---- _productview.less
---- _theme.less  //i changed this to _extend.less
---- _typography.less

I found the following DevDocs from the Magento website: http://devdocs.magento.com/guides/v2.1/frontend-dev-guide/css-guide/css_quick_guide_mode.html

It said that you need to use the _extend.less file for extending styles of the theme you're using (in my case magento/luma)

In this file I had my @imports to the files in my structure. I deployed it through grunt and it worked.

Anybody knows why _theme.less didn't work? Is it used for different purposes?

4
  • If you created _theme.less without carrying over the contents from Luma then you would have either lost some variables or you'll be loading them from the blank theme. Which would explain why you lost the Luma icons, if I remember right there is a variable with luma-icons or something similar set. – Ben Crook Jun 14 '17 at 8:51
  • Hi Ben, thanks for the insight. I will look further into it! – Prometheus Jun 14 '17 at 8:54
  • Hi @BenCrook and Roy ,I have similar issue while I am creating custom theme by overriding Blank theme.I am not getting luma-icons in mini cart drop down and also when we override any module with web folder then it is broking all design.Please suggest how you resolve it. – akgola Jul 6 '18 at 8:08
  • Can you raise a new question and show your file structure and code changes please? It's hard to debug with only a small bit of info. – Ben Crook Jul 6 '18 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.