0

When i try to install the migration tool from magento i get errors. ( see image )

Hope some one can help me out.

enter image description here

Now i have it installed and frond end and backend gives error :

There has been an error processing your request

Exception printing is disabled by default for security reasons.

If i check the log i see this. enter image description here

I have used bin/magento setup:upgrade and php bin/magento cache:clean php bin/magento indexer:reindex php bin/magento setup:static-content:deploy

Nothing helped.

  • Which magento version are you used? – Suresh Chikani Jun 12 '17 at 12:54
  • the newest from composer so 2.1.7 – Marlon van Leeuwaarde Jun 12 '17 at 13:03
  • Use this command : composer require magento/data-migration-tool:2.1.7 – Suresh Chikani Jun 12 '17 at 13:06
  • Same problem when i use that command – Marlon van Leeuwaarde Jun 12 '17 at 13:16
  • run first : composer update – Suresh Chikani Jun 12 '17 at 13:17
0

This issue resolved in this ticket composer error

please check it. disable tls in composer using the below command

composer config -g -- disable-tls true

or

nano ~/.composer/config.json ...

{
    "config": {
        "disable-tls": true,
        "secure-http": false
    }
}
  • If it is work please let me know – Rama Chandran M Jun 12 '17 at 13:29
  • This dont work. Check my edit above. – Marlon van Leeuwaarde Jun 12 '17 at 15:52
  • first run composer update – Rama Chandran M Jun 12 '17 at 16:00
  • i allready did that. It's already done because when i do it now it says "nothing to update" – Marlon van Leeuwaarde Jun 12 '17 at 16:07
  • what is the current error through is upgrade issue am i correct? – Rama Chandran M Jun 12 '17 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.