0

I am trying to install magento2 via composer using following command. My System specification is PHP Version 7.0.20-1~ubuntu16.04.1

composer create-project --repository-url=https://repo.magento.com/ magento/project-community-edition

I got the following error

Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.

Problem 1

- Installation request for magento/product-community-edition 2.1.7 -> satisfiable by magento/product-community-edition[2.1.7].
- magento/product-community-edition 2.1.7 requires php ~5.6.5|7.0.2|7.0.4|~7.0.6 -> your PHP version (7.1.6) does not satisfy that requirement.
1

Your error message already answered the question.

Magento 2 doesn't support PHP 7.1.x yet, please downgrade it to ~5.6.5|7.0.2|7.0.4|~7.0.6 There is a typo in DevDocs, if you need to know about the detail, please check this GitHub issue.

Good luck and welcome to Magento 2 :)

  • I know that, but my PHP Version is 7.0.20-1 and this PHP version is in range of 7.0.2|7.0.4|~7.0.6 – Kishor Hase Jun 16 '17 at 6:55
  • It said your PHP version (7.1.6), please notice that PHP CLI might use different version with your PHP FPM. I have 4 PHP version in my webserver too. – Toan Nguyen Nov 19 '17 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.