3

At some point recently our site stopped returning results for searches of product by part number. So far I've reindexed, I've tried all the different search modes, we've removed all disabled products (I heard there's a bug in the disabled products code that can cause whole categories to disappear from search), I've even disabled the extension that was updated recently. I've flushed the caches after each change just to make sure. Still no luck.

Searches for part numbers come up with "Your search returns no results." Searches for some other terms that are in part descriptions will find some, but not all the items with those terms in the description.

I'm not sure how to proceed from here. Ideas?

edit

Perhaps a better question is: "How does Magento search function?". What are the dependencies/expectations for an item to be found via search?

  • If it was working then there is a bug or change somewhere, stating the obvious, have you checked the fulltext table is filled. The problem with internal search is that it is <50% accurate, Sphinx/Lucene are 60-80% accurate, and Solr 98%. So it all depends on the level of accuracy you are looking for. – user2935 Apr 3 '14 at 17:14
  • We were using "like" search fine before, so even if fulltext table is full, wouldn't "like" still work? – Brian Knoblauch Apr 3 '14 at 17:42
1
  1. Check wether the catalogsearch_fulltext table is filled
  2. Check what the query looks like: It is build here: app/code/core/Mage/CatalogSearch/Model/Resource/Fulltext.php:311
  3. Check the catalogsearch_result table

    After a query, the results are cached in this table. So it might be, that magento get the "empty" result from there,

  4. Did you change the attribute part_number? If it is not searchable, you can't find it
  • Hmmm. I don't seem to have an attribute part_number. Is there supposed to be one by default? Unfortunately, I know almost nothing about Magento right now having no prior experience with the platform. I inherited the project at about the 90% completion point and don't know what all has been done in it. :-) – Brian Knoblauch Apr 8 '14 at 20:08
  • 1
    Wow. this will be a very tough experience for you. When you want to search for something it needs to be defined somewhere. It can be in the description or short description, but when it is a single information it should be saved into an attribute. all attributes (not only for products) can be seen in eav_attribute table. If you prefer the admin backend, have a look into Catalog > Attribute...(?) > Manage Attributes there is a list of all product attributes which are defined, part number is NO default but might be created. – Fabian Blechschmidt Apr 8 '14 at 21:16
  • 1
    I never did get that working, since posting the project has been through several other hands, and now is shut down. I'll accept this answer though as it does have good troubleshooting steps. – Brian Knoblauch May 13 '15 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.