0

I copied Magento project from server (live working server) to my local server and home page is displaying blank page.

Do I need any configuration before working with project (MySQL access credentials etc.)?

PS: I have my database file.

4
  • Check this: stackoverflow.com/a/42718836/949003. If it didnt work then comment, I will help to setup it. And yes you need to import database to local mysql and update config file for connection.
    – Jarnail S
    Jun 9 '17 at 12:25
  • i don't have app/etc/local.xml, there is only app/etc/local.xml.additional and app/etc/local.xml.template. which one should i modify?
    – MageD
    Jun 12 '17 at 9:26
  • Something seems wrong there. You will have to rename app/etc/local.xml.template to app/etc/local.xml
    – Jarnail S
    Jun 12 '17 at 10:10
  • OK, I'll try that
    – MageD
    Jun 16 '17 at 14:33
0

It may be caused by many reasons. Check one by one below points:

  1. check app/etc/local.xml file with db names are correct.
  2. check that URLs are correct in the 'core_config_data' table for paths:

web/unsecure/base_url
web/secure/base_url

  1. Delete the cache.
  2. Still if you get error, enable error_reporting and check.
0

I hope, you have followed correct procedure and are aware about Magento migration process.

To debug the problem, please check below points:

  • Open index.php in Magento root folder, add below lines anywhere in this file:

Mage::setIsDeveloperMode(true);

ini_set('display_errors', 1);

Refresh local website in browser and check for the errors.

  • Go to errors folder in Magento root and rename local.xml.sample file to local.xml and then refresh the browser for errors.

Please let me know if you still could not find any clue.

0

It could have many reasons. Just a few things that crossed my mind. Please check the following list:

  1. check db credentials from local.xml
  2. clear the cache from var/cache and the session from var/session
  3. did you change the base url from core_config_data
  4. virtual host issue. make sure that the settings for the virtual host is correct
  5. clear your browser cache. try incognito
  6. if you use linux, please remove the cache from tmp folder too

Enable dev mode from index.php, See if you got some warnings etc. Check the log files too :)

Mage::setIsDeveloperMode(true);
ini_set('display_errors', 1);

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.