3

When running deploy static content on my store i always need to add the locale at the end of the command or my store breaks.

bin/magento setup:static-content:deploy en_GB

I was wondering if I am doing anything wrong here and if i can set this so the locale is not required.

1

The accepted answer doesn't answer OP's question:

I was wondering if I am doing anything wrong here and if I can set this so the locale is not required

There is a way to ensure only used locales are deployed. You can employ GetPageSpeed n98-magerun2 commands for the job, e.g.:

php ./bin/magento setup:static-content:deploy $(n98-magerun2 deploy:locale:active)

You can save it to a script which is part of your deployment workflow, and then no matter what actual locales are used, only they will be "deployed", without having to hardcode them anywhere.

| improve this answer | |
7

Magento2 deploys only for en_US locale by default. And if you are using en_GB locale for your site then you need to always add the locale to ythe deploy command.

bin/magento setup:static-content:deploy en_GB
| improve this answer | |
1

You need deploy your language to run below command

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy en_GB en_US
php bin/magento cache:clean

Let me know if you have any issue.

| improve this answer | |
0

Try the code like that.

bin/magento setup:static-content:deploy --language en_GB

for reference please check Magento deploy command

| improve this answer | |
  • Please check it and let me know it is working fine. – Rama Chandran M Jun 8 '17 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.