1

When i import a csv file with product everythings is ok. Images are on admin product page. But in frontend there is nothing, just the broken image with the alt.

When i go to the image in admin and i press save (i do nothing, just direct save) the image appear in frontend.

I already try : setup:static-content:deploy index:reindex cache:clean

I don't know if you understand well, my english isn't very good.

2
  • Have you done indexing after product import. Might be that could be issue.
    – arushi
    Jun 6 '17 at 9:57
  • hi, yes sorry, i edit my post to add what i've done
    – Nundra
    Jun 6 '17 at 9:59
2

try the following menthod:

1.Please check your imported csv file inside column product_websites is empty or filled with base.

2.Do image resize php bin/magento catalog:images:resize

1
  • Yours welcome @Nundra
    – kamal
    Jun 6 '17 at 12:28
0

Add the following rows in your CSV:

  • base_image
  • base_image_label
  • thumbnail_image
  • thumbnail_image_labe
  • small_image
  • small_image_label

You have to upload the product images to Magento 2 pub/media/import folder.

Note: Make sure that all the images that you upload have the same name as in CSV.

Then upload the CSV file and enter /pub/media/import in the Image File Directory text field. Lastly, import the CSV.

1
  • Hi, i already do this, my problem is the image are in backend,but not in front end. I use the images:resize and it's ok.
    – Nundra
    Jun 6 '17 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.