0

I'm trying to import customers to a Magento 2 website. Data validation is OK (File is valid! To start import process press "Import" button), but when I click on import button, page gets stuck on please wait loader and I get error :

POST https://www.my-domain.com/administration/admin/import/start/key/8adc97…ad82c7953b3d1041f73b2365f835465e6552bba89c2b456/&form_key=5VWWozeXbFPTNSAr 500 (Internal Server Error) validation.min.js:6

I also tried to export / import existing customers (3) to be sure I did not have wrong data in my csv or too many customers.

Folders have the right permissions.

I'm using Magento 2.1.7 on a dedicated Linux server.

I can't find what could be wrong here, any idea ?

6
  • 1
    I'd check the apache error log file. Error 500 means that literally everything could have gone wrong - from an error in a PHP file to a timeout of your proxy, if you're using nginx for example. If your CSV file is very large, I'd assume it's something about memory_limit, post_max_size or upload_max_size Commented Jun 4, 2017 at 11:30
  • Yes, I was checking the logs right now. I have mod_fcgid: stderr: PHP Fatal error: Uncaught Error: Call to a member function getBackendModel() on null in /var/www/vhosts/my-domain.com/httpdocs/vendor/magento/module-customer-import-export/Model/Import/Customer.php:390, referer: my-domain.com/administration/admin/import/index/key/…. I also have this error with the small file I exported and tried ti reimport without any changes, with only 3 customers..
    – David
    Commented Jun 4, 2017 at 11:39
  • 1
    I think customer attributes that have been added by you or an extension can cause this problem. Commented Jun 4, 2017 at 11:42
  • Indeed, I added 2 customer attributes, one following link and one directly in database with phpmyadmin. The second one is causing the problem, I have to check what I did wrong there. Thanks a lot for you help.
    – David
    Commented Jun 4, 2017 at 11:52
  • I forgot to add the attribute in entity_attribute_id, problem soved ! Thanks again.
    – David
    Commented Jun 4, 2017 at 12:01

1 Answer 1

0

I had the same issue. Followed this and resolved https://github.com/magento/magento2/issues/28115

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.