2

Trying to install the security patch SUPEE-9767 onto M1 EE v1.13.1.0 and i'm receiving the following error:

Hunk #1 FAILED at 225. 1 out of 1 hunk FAILED -- saving rejects to file app/design/frontend/enterprise/default/template/persistent/checkout/onepage/billing.phtml.rej

I've checked the line in file indicated in the error and here is the related block of code:

<div class="input-box">   <!--(this is line 255)-->
<input type="password" name="billing[confirm_password]" title="<?php echo 
$this->__('Confirm Password') ?>" id="billing:confirm_password" 
class="input-text required-entry validate-cpassword" />
</div>

Any help would be appreciated.

1

Another reason could be that you modified this file and thus it is different than the original version of it.

To fix that:

  • Backup this file
  • Download the original file of your Magento version
  • Apply the patch
  • Compare your backup with the new file
  • Copy the new file into your custom theme and apply the changes from your backup file into it
  • Where can I download the original file of my magento version? I have 1.9.3.0 – Black Feb 12 at 18:28
1

What I did to resolve the problem:

  1. Pulled original file version of app/design/frontend/enterprise/default/template/persistent/checkout/onepage/billing.phtml and placed in directory.

  2. Moved modified core file to template override directory. One thing to note in order to retain the security changes for the template over ride file, I had to manually make the changes to the template file version directly.

    Example of moving core file to template override directory:

    app/design/frontend/enterprise/default/template/persistent/checkout/onepage/billing.phtml moved too
    app/design/frontend/YOUR_TEMPLATE/YOUR_TEMPLATE/template/persistent/checkout/onepage/billing.phtml

  3. Installed patch- success

Hope this helps someone else out there.

Answer credit goes to Raphael at Digital Pianism as his answer is correct and placed here before mine, just wanted to provide a step by step of what I did to successfully install the patch.

0

Hello this might be fail because of following two issues :

  1. Your file has wrong permission set permission of 644 to that file and apply patch again.
  2. Your are applying this patch on server. so please zip this patch file and then upload to your server and unzip that file at server, after that apply this patch.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.