1

I have installed the

"snowdog/theme-blank-sass": "^0.10.1"

Now I am trying to replace it with our fork, versioned 0.110.1 (just added 100)

  "repositories": [
    {
      "type": "composer",
      "url": "https://repo.magento.com/"
    },
    {
      "type": "vcs",
      "url": "https://github.com/iMi-digital/magento2-theme-blank-sass.git"
    }
  ],

I am getting

$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)                  
Package operations: 0 installs, 1 update, 0 removals
  - Updating snowdog/theme-blank-sass (0.10.1 => 0.110.1): Downloading (connectiDownloading (100%)         


  [ErrorException]                                             
  Unable to find deploy strategy for module: no known mapping  

Edit:

Deleting the old module from the vendor folder and

composer require snowdog/theme-blank-sass=dev-imi-develop

worked...

But I can not update the module - I always have to remove the module first via rm -rf vendor/snowdog/theme-blank-sass

edit: full composer json

{
    "name": "example/example",
    "description": "Example",
    "type": "project",
    "license": [
    "OSL-3.0",
    "AFL-3.0"
    ],
    "require": {
    "php": "~5.6.0|~7.0.0",
    "magento/product-community-edition": "2.1.6",
    "composer/composer": "@alpha",
    "firegento/magesetup2": "dev-develop",
    "splendidinternet/mage2-locale-de-de": "^1.13",
    "snowdog/frontools": "^1.4",
    "snowdog/theme-blank-sass": "dev-imi-develop",
    "magepal/magento2-gmailsmtpapp": "^1.4",
    "adyen/module-payment": "^2.0",
    "elasticsearch/elasticsearch": "^5.2",
    "ves/magento2-imageslider" :"dev-patch-1"
    },
    "require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.2.2",
    "friendsofphp/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
    },
    "config": {
    "use-include-path": true
    },
    "autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ],
    "exclude-from-classmap": [
        "**/dev/**",
        "**/update/**",
        "**/Test/**"
    ]
    },
    "autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "repositories": {
    "magento": {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    "snowdog_theme_blank_sass": {
        "type": "git",
        "url": "https://github.com/iMi-digital/magento2-theme-blank-sass"
    },
    "ves_magento2_imageslider": {
        "type": "git",
        "url": "https://github.com/ihor-sviziev/imageslider"
    }
    },
    "extra": {
    "magento-force": "override",
    "auto-append-gitignore": "true"
    }
}

Updated composer json

{
    "name": "example/example",
    "description": "Example",
    "type": "project",
    "license": [
    "OSL-3.0",
    "AFL-3.0"
    ],
    "require": {
    "php": "~5.6.0|~7.0.0",
    "magento/product-community-edition": "2.1.6",
    "composer/composer": "@alpha",
    "firegento/magesetup2": "dev-develop",
    "splendidinternet/mage2-locale-de-de": "^1.13",
    "snowdog/frontools": "^1.4",
    "snowdog/theme-blank-sass": "dev-imi-develop",
    "magepal/magento2-gmailsmtpapp": "^1.4",
    "adyen/module-payment": "^2.0",
    "elasticsearch/elasticsearch": "^5.2",
    "ves/magento2-imageslider" :"dev-patch-1"
    },
    "require-dev": {
    "phpunit/phpunit": "4.1.0",
    "squizlabs/php_codesniffer": "1.5.3",
    "phpmd/phpmd": "@stable",
    "pdepend/pdepend": "2.2.2",
    "friendsofphp/php-cs-fixer": "~1.2",
    "lusitanian/oauth": "~0.3 <=0.7.0",
    "sebastian/phpcpd": "2.0.0"
    },
    "config": {
    "use-include-path": true
    },
    "autoload": {
    "psr-4": {
        "Magento\\Framework\\": "lib/internal/Magento/Framework/",
        "Magento\\Setup\\": "setup/src/Magento/Setup/",
        "Magento\\": "app/code/Magento/"
    },
    "psr-0": {
        "": "app/code/"
    },
    "files": [
        "app/etc/NonComposerComponentRegistration.php"
    ],
    "exclude-from-classmap": [
        "**/dev/**",
        "**/update/**",
        "**/Test/**"
    ]
    },
    "autoload-dev": {
    "psr-4": {
        "Magento\\Sniffs\\": "dev/tests/static/framework/Magento/Sniffs/",
        "Magento\\Tools\\": "dev/tools/Magento/Tools/",
        "Magento\\Tools\\Sanity\\": "dev/build/publication/sanity/Magento/Tools/Sanity/",
        "Magento\\TestFramework\\Inspection\\": "dev/tests/static/framework/Magento/TestFramework/Inspection/",
        "Magento\\TestFramework\\Utility\\": "dev/tests/static/framework/Magento/TestFramework/Utility/"
    }
    },
    "minimum-stability": "dev",
    "prefer-stable": true,
    "repositories": [
    {
        "type": "composer",
        "url": "https://repo.magento.com/"
    },
    {
        "type": "vcs",
        "url": "https://github.com/iMi-digital/magento2-theme-blank-sass"
    },
    {
        "type": "vcs",
        "url": "https://github.com/ihor-sviziev/imageslider"
    }
    ],
    "extra": {
    "magento-force": "override",
    "auto-append-gitignore": "true"
    }
}

Steps to reproduce:

composer install composer require snowdog/theme-blank-sass=dev-master

9
  • Maybe this issue? github.com/AydinHassan/magento-core-composer-installer/issues/9
    – Alex
    May 26, 2017 at 17:17
  • Could you show whole composer.json file of your forked theme?
    – igloczek
    Jun 17, 2017 at 5:40
  • You should change the name of the package to your custom, conflicting with a publicly available package isn't good practice at all.
    – igloczek
    Jun 17, 2017 at 5:42
  • You can see the composer.json on github imi digital... And I did it lots of times before with the same name...
    – Alex
    Jun 17, 2017 at 5:52
  • Surprisingly, b/c your releases tagging methods doesn't follow any rules, everything works fine for me.
    – igloczek
    Jun 17, 2017 at 6:31

1 Answer 1

2
+200

Replace

"extra": {
    "magento-force": "override",
    "auto-append-gitignore": "true"
}

with

"extra": {
    "magento-force": "override"
}

And it will work.

If you still need this option report an issue on M2 Github, b/c they are replacing magento-hackathon/magento-composer-installer, which seems to contain this feature, with own magento/magento-composer-installer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.