0

I have a Magento 2 store that I just configured memcached on. Everything seemed to be working well and using the guide on the magento site I was able to verify it was working via telnet.

However, when I tried to access the Web Setup Wizard section from the Magento back end I received this error

Fatal error: Uncaught Exception: Warning: SessionHandler:1(): open(127.0.0.1:20000/sess_19qiu342pfd61u99a14t054m22, O_RDWR) failed: No such file or directory (2) in /home/vanscosu/public_html/vendor/magento/framework/Session/SaveHandler/Native.php on line 22 in /home/vanscosu/public_html/vendor/magento/framework/App/ErrorHandler.php:61 Stack trace: #0 [internal function]: Magento\Framework\App\ErrorHandler->handler(2, 'SessionHandler:...', '/home/vanscosu/...', 22, Array) #1 /home/vanscosu/public_html/vendor/magento/framework/Session/SaveHandler/Native.php(22): SessionHandler->read('19qiu342pfd61u9...') #2 /home/vanscosu/public_html/vendor/magento/framework/Session/SaveHandler.php(93): Magento\Framework\Session\SaveHandler\Native->read('19qiu342pfd61u9...') #3 [internal function]: Magento\Framework\Session\SaveHandler->read('19qiu342pfd61u9...') #4 /home/vanscosu/public_html/vendor/magento/framework/Session/SessionManager.php(189): session_start() #5 /home/vanscosu/public_html/var/generation/Magento/Backend/Model/Auth in /home/vanscosu/public_html/vendor/magento/framework/App/ErrorHandler.php on line 61

That is the only thing I've found that doesn't work, but I obviously need it to manage various plugins and extensions. I've disabled memcached and returned session storage to the file system for now, but I would like to solve this.

Magento 2.1.5 PHP 7.0.19

0

This issue cause by Web setup wizard not load config from env.php

You can fix this by this ways:

Change php setting on php.ini

session.save_handler=memcached
session.save_path=localhost:11211
  • Welcome to Magento Stack Exchange! Please note that signatures are removed, especially when they contain links. Such links belong in your profile, if you want to. – Glorfindel Dec 6 '17 at 16:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.