1

Working with Magento EE 1.14.2.4 running on CentOS LAMP stack. Attempting to utilize Solr Search.

I'm creating a staging site. The codebase and server configuration are essentially mirrors of production. Everything seems configured correctly but when I attempt to run Test Connection of Solr from System > Config > Catalog > Catalog > Catalog Search I get "Connection failed! Test again?".

I know I'm running Solr, I'm starting it up with this command which is taken from the Magento 1.x / Solr doc:

java -jar /root/solr/apache-solr-3.6.2/example/start.jar

Dev Document: http://devdocs.magento.com/guides/m1x/other/ht_magento-solr.html

To rule out any firewalls or security rules, I monitored incoming traffic to Solr's default port (i.e. 8983):

tcpdump -i eth0 port 8983

Ran the test from Magento's admin, no incoming traffic/packets.

I then ran the following command to ensure the port was open and receiving:

wget mysstagingsite.com:8983

404, but at least a server response and a visible request in my tcpdump.

Also to be clear: My codebase, database and Solr instance are all hosted on a single environment, so the request Solr would be making would be to 127.0.0.1:8983, so I tested this command as well:

wget 127.0.0.1:8983

Same result, packets and request visible.

For whatever reason, the Solr connectivity test in the admin isn't actually requesting anything - it seems. So what could be wrong? Solr was part of Magento EE, all I did was install according to the dev docs provided by Magento and it worked on my production site. How do I proceed with debugging as there isn't necessarily a Magento extension to reinstall?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.