1

I'm getting this constant exception when running the static content deploy command and here is my redis section from the env.php file

'session' => 
  array (
    'save' => 'redis',
    'redis' => 
    array (
      'host' => '127.0.0.1',
      'port' => '6379',
      'password' => '',
      'timeout' => '3.5',
      'persistent_identifier' => '',
      'database' => '0',
      'compression_threshold' => '2048',
      'compression_library' => 'gzip',
      'log_level' => '1',
      'max_concurrency' => '6',
      'break_after_frontend' => '5',
      'break_after_adminhtml' => '30',
      'first_lifetime' => '600',
      'bot_first_lifetime' => '60',
      'bot_lifetime' => '7200',
      'disable_locking' => '0',
      'min_lifetime' => '60',
      'max_lifetime' => '2592000',
    ),
  ),

1 Answer 1

4

we had a similar error after the upgrade to 2.1.6 when deploying static files.

It seemed like throwing a random exception not be able to access the redis cache.

It seems to be a problem with the parallel procession of the static files compilation.

For now, as a workaround, we are deploying the files with the -j 1 option, to only start one process:

bin/magento setup:static-content:deploy -j 1
1
  • The issue is still present on 2.2.2 version of Magento. Even -j 1 doesn't help.
    – Gediminas
    Commented Dec 15, 2017 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.