2

I'm using custom magento theme, and changed a few things on it. I also wrote this problem to where I bought it.

I've been researched everything about that but nothing helped me.

When I use custom template's /layout/checkout.xml file It’s not progress to “payment information” tab, and also right sidebar checkout progress not working

If I change checkout.xml file from base theme’s checkout.xml file payment information can work very well but checkout progress still not working.

I'm trying to fix checkout progress problem.

Do you know any solution, anynone has same problem or just me?

  • Anything in Magneto logs (assuming you have them enabled) or/and JavaScript console? – user487772 Mar 27 '14 at 11:29
  • Also it's not a good practice to rewrite checkout.xml in a custom theme. But how makes good themes these days :( – user487772 Mar 27 '14 at 11:31
  • @Tim I enabled magento logs, but browser console is pretty clean even in all checkout step. – Ibrahim Mumcu Mar 27 '14 at 11:34
  • You can also try to check XHR responses at the Network tab of your browser. The request to failed checkout step should leave its trace there. – user487772 Mar 27 '14 at 11:43
  • @Tim Actually, I revert to base theme's checkout.xml code. Now all step work very well but not checkout progress. Can I see progress's response on network tab? – Ibrahim Mumcu Mar 27 '14 at 11:59
2

I fixed this on my site. Go to /app/design/frontend/base/default/template/checkout/onepage/payment.phtml or to your custom theme's payment.phtml to edit some code.

<fieldset>
    <?php echo $this->getChildHtml('methods') ?>
</fieldset>

this fieldset needs an ID to progress

<fieldset id="checkout-payment-method-load">
    <?php echo $this->getChildHtml('methods') ?>
</fieldset>

This should fix it for you. if not, be sure to clear all your cache.

  • glad you got this sorted, you can mark this answer as accepted if you think it will help others. – David Manners May 24 '14 at 8:09
2

after upgrade magento this issue will occurs because your current theme is older magento files so pleas rename your checkout.xml to checkout.xml-- and rename template checkout folder to checkout-- so that will load from base/default and this will solve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.