Magento 2.1.0
Porto theme

OK - so I thought I was so clever by waiting until the next major version after 2.0.0 so I would get a good (and working) version of the new Magento. I installed 2.1.0 and the ONLY modification I had to make was to install a theme. I picked the PORTO theme, installed it and spent many many many hours configuring the theme on about dozen different websites/stores/domains.

Now everything works EXCEPT:

I am getting the "**Attention something went wrong**" Error when I click on Sales > Orders. It is the only place (and the most important place) in the Admin panel where I get this Error.

I searched for possible fixes for this problem and they always talk about disabling the Review Module. I tried to disable and enable this Magento_Review Modules Output module in

STORES > Configuration > Advanced > Advanced >

But it did not help. Any other ideas? :-*

EDITED: I tried the 3 suggested fixes below and they do not work. Specifically, when I run the script posted by Rafael Corrêa Gomes - it seems to knock out my Porto theme. And upgrading Magento to the latest version will NOT work because if I do that - I will loose all the work (design changes) I've done in all those stores in Porto.

Here is my exception.log:

[2017-05-14 23:18:57] main.CRITICAL: exception 'Magento\Framework\Exception\FileSystemException' with message 'Cannot read contents from file "/home/MYsite/public_html/pub/static/frontend/Smartwave/porto/en_US/mage/requirejs/mixins.js" Warning!file_get_contents(/home/MYsite/public_html/pub/static/frontend/Smartwave/porto/en_US/mage/requirejs/mixins.js): failed to open stream: No such file or directory' in /home/MYsite/public_html/vendor/magento/framework/Filesystem/Driver/File.php:149
Stack trace:
#0 /home/MYsite/public_html/vendor/magento/framework/Filesystem/Directory/Read.php(207): Magento\Framework\Filesystem\Driver\File->fileGetContents('/home/MYsite/pub...', NULL, NULL)
#1 /home/MYsite/public_html/vendor/magento/framework/View/Asset/Source.php(262): Magento\Framework\Filesystem\Directory\Read->readFile('mixins.js')
#2 /home/MYsite/public_html/vendor/magento/framework/View/Asset/Source.php(143): Magento\Framework\View\Asset\Source->createChain(Object(Magento\Framework\View\Asset\File), '/home/MYsite/pub...', 'mixins.js')
#3 /home/MYsite/public_html/vendor/magento/framework/View/Asset/Source.php(113): Magento\Framework\View\Asset\Source->preProcess(Object(Magento\Framework\View\Asset\File))
#4 /home/MYsite/public_html/vendor/magento/framework/View/Asset/File.php(163): Magento\Framework\View\Asset\Source->getContent(Object(Magento\Framework\View\Asset\File))
#5 /home/MYsite/public_html/vendor/magento/framework/View/Asset/MergeStrategy/Direct.php(70): Magento\Framework\View\Asset\File->getContent()
#6 /home/MYsite/public_html/vendor/magento/framework/View/Asset/MergeStrategy/Direct.php(52): Magento\Framework\View\Asset\MergeStrategy\Direct->composeMergedContent(Array, Object(Magento\Framework\View\Asset\File))
#7 /home/MYsite/public_html/vendor/magento/framework/View/Asset/MergeStrategy/FileExists.php(44): Magento\Framework\View\Asset\MergeStrategy\Direct->merge(Array, Object(Magento\Framework\View\Asset\File))
#8 /home/MYsite/public_html/vendor/magento/framework/View/Asset/Merged.php(97): Magento\Framework\View\Asset\MergeStrategy\FileExists->merge(Array, Object(Magento\Framework\View\Asset\File))
#9 /home/MYsite/public_html/vendor/magento/framework/View/Asset/Merged.php(157): Magento\Framework\View\Asset\Merged->initialize()
#10 /home/MYsite/public_html/vendor/magento/framework/View/Page/Config/Renderer.php(358): Magento\Framework\View\Asset\Merged->rewind()
#11 /home/MYsite/public_html/vendor/magento/framework/View/Page/Config/Renderer.php(251): Magento\Framework\View\Page\Config\Renderer->renderAssetHtml('<script  type="...', Object(Magento\Framework\View\Asset\Merged))
#12 /home/MYsite/public_html/vendor/magento/framework/View/Page/Config/Renderer.php(226): Magento\Framework\View\Page\Config\Renderer->renderAssetGroup(Object(Magento\Framework\View\Asset\PropertyGroup))
#13 /home/MYsite/public_html/vendor/magento/framework/View/Page/Config/Renderer.php(99): Magento\Framework\View\Page\Config\Renderer->renderAssets(Array)
#14 /home/MYsite/public_html/vendor/magento/framework/View/Result/Page.php(235): Magento\Framework\View\Page\Config\Renderer->renderHeadContent()
#15 /home/MYsite/public_html/vendor/magento/framework/View/Result/Layout.php(164): Magento\Framework\View\Result\Page->render(Object(Magento\Framework\App\Response\Http\Interceptor))
#16 /home/MYsite/public_html/vendor/magento/framework/Interception/Interceptor.php(74): Magento\Framework\View\Result\Layout->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#17 /home/MYsite/public_html/vendor/magento/framework/Interception/Chain/Chain.php(70): Magento\Framework\View\Result\Page\Interceptor->___callParent('renderResult', Array)
#18 /home/MYsite/public_html/vendor/magento/framework/Interception/Chain/Chain.php(63): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'renderResult', Object(Magento\Framework\View\Result\Page\Interceptor), Array, 'result-varnish-...')
#19 /home/MYsite/public_html/vendor/magento/module-page-cache/Model/Controller/Result/VarnishPlugin.php(74): Magento\Framework\Interception\Chain\Chain->Magento\Framework\Interception\Chain\{closure}(Object(Magento\Framework\App\Response\Http\Interceptor))
#20 /home/MYsite/public_html/vendor/magento/framework/Interception/Chain/Chain.php(67): Magento\PageCache\Model\Controller\Result\VarnishPlugin->aroundRenderResult(Object(Magento\Framework\View\Result\Page\Interceptor), Object(Closure), Object(Magento\Framework\App\Response\Http\Interceptor))
#21 /home/MYsite/public_html/vendor/magento/framework/Interception/Interceptor.php(138): Magento\Framework\Interception\Chain\Chain->invokeNext('Magento\\Framewo...', 'renderResult', Object(Magento\Framework\View\Result\Page\Interceptor), Array, 'result-builtin-...')
#22 /home/MYsite/public_html/vendor/magento/module-page-cache/Model/Controller/Result/BuiltinPlugin.php(67): Magento\Framework\View\Result\Page\Interceptor->Magento\Framework\Interception\{closure}(Object(Magento\Framework\App\Response\Http\Interceptor))
#23 /home/MYsite/public_html/vendor/magento/framework/Interception/Interceptor.php(142): Magento\PageCache\Model\Controller\Result\BuiltinPlugin->aroundRenderResult(Object(Magento\Framework\View\Result\Page\Interceptor), Object(Closure), Object(Magento\Framework\App\Response\Http\Interceptor))
#24 /home/MYsite/public_html/var/generation/Magento/Framework/View/Result/Page/Interceptor.php(130): Magento\Framework\View\Result\Page\Interceptor->___callPlugins('renderResult', Array, Array)
#25 /home/MYsite/public_html/vendor/magento/framework/App/Http.php(139): Magento\Framework\View\Result\Page\Interceptor->renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#26 /home/MYsite/public_html/vendor/magento/framework/App/Bootstrap.php(258): Magento\Framework\App\Http->launch()
#27 /home/MYsite/public_html/index.php(39): Magento\Framework\App\Bootstrap->run(Object(Magento\Framework\App\Http))
#28 {main} [] []
[2017-05-15 07:47:11] main.CRITICAL: exception 'PDOException' with message 'SQLSTATE[HY000]: General error: 3 Error writing file '/tmp/#sql4e3_dd7_0.frm' (Errcode: 28 - No space left on device)' in /home/MYsite/public_html/vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php:228
Stack trace:
#0 /home/MYsite/public_html/vendor/magento/zendframework1/library/Zend/Db/Statement/Pdo.php(228): PDOStatement->execute(Array)
#1 /home/MYsite/public_html/vendor/magento/framework/DB/Statement/Pdo/Mysql.php(95): Zend_Db_Statement_Pdo->_execute(Array)
#2 /home/MYsite/public_html/vendor/magento/zendframework1/library/Zend/Db/Statement.php(303): Magento\Framework\DB\Statement\Pdo\Mysql->_execute(Array)

#3 /home/MYsite/public_html/vendor/magento/zend

PS: I just found out that a different (not Admin) user account is showing SALES - ORDERS while my Admin account gives the Error. What could be the reason for that?

  • Can you post the exception log? Go to app/bootstrap.php . Uncomment the line ini_set('display_errors', 1); Now your exception log will have errors. Just post the last stack trace please. It's created in var/log/exception.log – Abhishek Jakhotiya May 16 '17 at 14:38
  • @Abhishek Jakhotiya - thank you Abhishek for the suggestion. I posted the result up above in my original post.... – Allysin May 16 '17 at 16:02

This issue was reported many times on the versions before 2.1.5. Like this issues at the Github.

https://github.com/magento/magento2/issues/5418 https://github.com/magento/magento2/issues/6297

So try run these commands on the root of your installation, if don't resolve it, try to upgrade your Magento to the last version.

alias mage="php -d memory_limit=-1 -f bin/magento"

chmod -R 775 pub/static/ var/ pub/media/ && 
rm -rf var/view_preprocessed/ var/cache/ var/page_cache/ var/tmp/ var/generation/ pub/static/frontend/ vendor/* ; 
composer install && composer update -vvv && 
php -r "opcache_reset();" 
mage module:disable Magento_Review ; 
mage cache:flush && 
mage indexer:reindex && 
mage setup:upgrade && 
mage setup:static-content:deploy && 
mage setup:db-data:upgrade && 
mage dev:source-theme:deploy && 
chmod -R 775 pub/static/ pub/media/ var/
| improve this answer | |
  • I followed your steps and now I get the following Error on the front end: "Autoload error Vendor autoload is not found. Please run 'composer install' under application root directory." Any ideas? – Allysin May 13 '17 at 19:17
  • @Allysin I did a change, try to run the snippet above again, please. – Rafael Corrêa Gomes May 14 '17 at 2:05
  • Thank you for helping. I forgot to mention I have the Porto theme installed and configured on about a dozen different stores. When I run your script - the Porto theme stops working. Is there any way to work around that? I don't want to loose all those (long) hours of work with the Porto theme. If I update - it will likely destroy my Porto theme configuration also. Thanks again for helping. I updated my original post as well. – Allysin May 16 '17 at 14:39

We also face this type of issue sometime on config and other admin grid like CMS, catalog. First check if there any errors reported in exception logs, nginx/apache/php-fpm error logs.

If there is no errors on server side then there must some issue with data which loads inside form using the JS call so please check the console log in browser and find out the JS error.

| improve this answer | |

Disabling a module is different from disabling the module output. If you disable the output, the code is still executed, and so the error that leads to the message is still there. You can disable a module by logging into your webserver with SSH, then navigating to the magento2-directory and issuing this command:

php bin/magento module:disable [module-name]

..., so for example:

php bin/magento module:disable Magento_Review

| improve this answer | |

Have you noticed the PDO exception that says no space on the device. If your mysql can not store the data. It can be because there is no space as the error suggests or something wrong with that particular file(/tmp/#sql4e3_dd7_0.frm). Free up some disk space and try restarting mysql. Also if static-content deploy didn't create the file /home/MYsite/public_html/pub/static/frontend/Smartwave/porto/en_US/mage/requirejs/mixins.js then manually create empty file at that path or copy a valid file from somewhere else. Doing these things will either fix issue or we will have at least know the actual issue. Let me know

| improve this answer | |
  • Thank you again for your suggestions. There definitely is enough space (it is an expensive server with 50 GB free) - I have, however, allocated another 1 GB of space to this account specifically. I restarted the HTTP Server (Apache Web Server) and SQL Server (MySQL) and also the entire server but it did not help. There is a file mixins.js at /home/MYsite/public_html/pub/static/frontend/Smartwave/porto/en_US/mage/requirejs/ but it is a LINK. My friend checked and says the link is valid though. He also says that all the file permissions are set correctly. any other ideas? – Allysin May 17 '17 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.