I am trying to import products using magmi. But it cannot create directories to copy images. I am getting this error.

Image attributes processor v1.0.25 - error creating media/catalog/product/f/a: 2,mkdir() [function.mkdir]: Permission denied

The directory media/catalog/product/ has 777 permissions but it does not solve the problem.

  • Hi Tasawer, can you give us the exact error that you're receiving? It is likely to be a permission error. Using 777 probably will solve the problem, but there will be a more precise answer. Commented Mar 27, 2014 at 8:24
  • @james question edited Commented Mar 27, 2014 at 8:40
  • do the subdirectories exist and do they have the same owner/permissions as the catalog/product directory? Commented Mar 27, 2014 at 18:28
  • all available sub categories have 777 permissions, but looks like magmi is creating some as well. Commented Mar 27, 2014 at 19:44
  • How did you solve it exactly? Can you list the steps? I can't seem to get it to work. I'm having the same issues.
    – user12432
    Commented Jul 22, 2014 at 6:26

1 Answer 1


I solved this by putting

Filesystem Path to magento directory: ../../

  • Hello, I got same issue.. Can I know more details your solution? Where should I put the line you mention? can I know example if my domain is 'mydomain.com?
    – Yohan
    Commented May 5, 2015 at 12:35
  • 3
    In global Magmi settings you can set Magento path
    – turson
    Commented Nov 7, 2016 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.