0

my transactional emails are not sending (new inquiry, new order, etc). And i've tried the solutions I could find here but none seems to work. my sales emails are enabled. i set up cron job at cpanel. but my cron jobs are not running. (i've nothing in var/log/cron) i've tried commenting out the mail queue, also did not work. the thing is, it USED to work. before i changed to SSL and before i added in my store email address. i don't know if that's an issue. previously it would send the mail as from "owner@example.com". also, i'm using a clone script from apptha (airhotels). could that be an issue?

please help, thank you!

0

First thing is to double check you have your cron job setup correctly. Review http://www.ecommercegorilla.com/how-to-setup-a-magento-cronjob/ and ensure you have it setup correctly.

If you are positive the cron is setup correctly and still not running try editing the cron.php in your store root.

After:

$isShellDisabled = (stripos(PHP_OS, 'win') === false) ? $isShellDisabled : true;

Add the following line:

$isShellDisabled = true;

More troubleshooting can be found at

http://www.ecommercegorilla.com/troubleshooting-a-magento-cronjob/

| improve this answer | |
0

Ensure that you have installed sendmail email service in your server. If not contact your hosting provider to install sendmail or setup SMTP in your server, so the email service will work. Cron job is used for time based scheduler and this has nothing to do with sending email.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.