0

Both my beta and live sites are on version 1.9.2.1

I run the update process on beta than live (of course)

My live site has 2 menu options under System > Permission, blocks and variables, these do not exist on beta. I did not notice this before as previously I did not have a need for them, but now I do for a slider I would like to add in.

I have added the slider to live, as it was a simple fix, but I would love to be able to have beta match it and no idea why the pages do not exist.

I tried using the url from live, appending the portion between /index.php and '/key/` into the beta url. the pages are not there.

I am assuming something didn't happen during an upgrade that stopped it from installing that portion on beta.

I just need to know what files I would need to move from live to beta to fix it?


UPDATE 1

per the suggestion of Rafael Corrêa Gomes below I have run the SUPEE-6788 fixer file from Github with no change (menu item still not visible, no ability to use block)

Script on Github: https://github.com/rhoerr/supee-6788-toolbox

Command to run: php -f fixSUPEE6788.php -- fixWhitelists


UPDATE 2

the database table permission_block exists in my database, I have manually entered the block for my slider and it is still not allowing it.

No log files indicating a conflict, and all the same mods/plugins are installed on both beta and live (though live does have my menu items, while beta is not showing it)


UPDATE 3

I have copied all of the files in SUPEE-6788 from my live site to beta (as all processes are done on both, they should be the same, right?) and now I have my menu items... but my slider is still not showing on the homepage.

In System > Permission, blocks I have the block bannerslider/default set to Allowed, but the homepage is not displaying the slider. Uncertain, at this point, if this is a new issue, or still part of the original problem. But, I am leaning to part of the original problem as it seems more logical that it would be to me.

No errors in any logs (in the beta site all error logging is on), and the slider works on the main site, just not in beta, which is why I believe the beta sites issue in my original question is still the issue

1

I guess that you have some third-party extension that is causing it. Check if all patches are the same installed on the both environments, then run this script on the link below into the root of your Magento installation, so it'll automatically add the block and variables required.

Script on Github: https://github.com/rhoerr/supee-6788-toolbox

Command to run:

php -f fixSUPEE6788.php -- fixWhitelists
  • I am pretty sure that all patches are the same on both systems, is there a way to compare? Also, I ran the php -f fixSUPEE6788.php -- fixWhitelists and it did not fix the issue (still no menu, but it did report that Blocks that are not whitelisted: bannerslider/default in cms_page=home), which is true and what I am trying to fix – Kender May 5 '17 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.